IGMPProxy config (MEO ISP from Portugal)

Hey guys, I'm hoping someone can help me with this.

I installed openWRT on my Archer C7 v2 and I'm trying to use it as a standalone router. Now, my ISP (MEO) uses VLAN 12 to brodcast the signal. I managed to create the VLAN, tagged it to eth1 and changed my WAN and WAN6 device to eth1.12. I get instant internet connection. So far so good.

Then I installed IGMPProxy to enable multicast, configured it using the ISP IP's (I also tried with 0.0.0.0/0) but the problem is my STB keeps freezing after 10 seconds or so. I know this happens because the first seconds are broadcasted using Unicast and then the Multicast kicks in. Well, the freezes tell me that something's off with my igmpproxy configuration. I know I'm not supposed to create the firewall rules by hand (I used option zone wan and option zone lan). If I check my /var/etc/igmpproxy here's what I get:

quickleave

phyint eth1.12 upstream ratelimit 0 threshold 1
	altnet 194.65.46.0/23
	altnet 10.173.0.0/16
	altnet 213.13.16.0/20

phyint br-lan downstream ratelimit 0 threshold 1

I'm probably doing something wrong but can't figure out what it is. Here's hoping someone can help me solve this. Thanks in advance.

  • Can you show your /etc/config/igmpproxy config file?
  • Have you tried changing the quickleave setting yet?
  • 0.0.0.0/0 can be tested if you don't know the SRC

Thanks for the reply mate.

config igmpproxy
	option quickleave 1
	option verbose 2 #[0-3](none, minimal[default], more, maximum)

config phyint
	option network wan
	option zone wan
	option direction upstream
	list altnet 0.0.0.0/0
	# list altnet 194.65.46.0/23
	# list altnet 10.173.0.0/16
	# list altnet 213.13.16.0/20

config phyint
	option network lan
	option zone lan
	option direction downstream
	# list whitelist 232.0.0.0/8

Yeah, I tried changing it to "0" (I saw it on another post), thought it might work... didn't.

I've been using on my latest testing to narrow down the issues.

Is there something on the log that might give me some hint on what's wrong?

I had this router working with stock firmware for a few years with no issues whatsoever.

Edit: something I just noticed. On same channels, whenever the image freezes, if I rewind a few seconds, the stream goes on without any further hiccups. This means the multicast is working correctly, right?

Someone? :roll_eyes:

Well, maybe it's a little late to help with your setup, but I've finally figured out why it was not working. Your igmpproxy settings are correct. What is missing from all the guides about MEO's IPTV (there is one on ubiquity forum, a couple for pfsense and a few threads on meo forum) is that ISP uses IGMPv2 for multicast traffic.

Here is the relevant part from the network config:

-- cut --
config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth2'
	list ports 'eth3'
	option igmp_snooping '1' # <===== enable IGMP Snooping on LAN bridge

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '12'
	option name 'fibre12'
	option igmpversion '2'   # <===== force IGMP version 2 on WAN iface

config interface 'wan'
	option device 'fibre12'
	option proto 'dhcp'
-- cut --

And there is no need to manually set up firewall rules - igmproxy will do it automatically with option zone lines.

Hope this helps!