I am new to openwrt. I have a fairly default install up and running. I added SQM and enabled cake, and I changed the default WAN in rule from reject to drop.
I set up the basic forwarder and provided it google's dns as it's upstream forwarders and my DHCP clients use the openwrt forwarder as their DNS.
iCloud Private Relay, a VPN type service, complains that it is not allowed on this network. I would like to allow it, and allow any clients to be allowed to use any external DNS.
Can anyone point me in the right direction? I gather by searching that there are likely "canary domains" involved, but I don't understand which features or configuration would not be allowing these lookups out of the box.
I have reinstalled today and created a minimal config.
Set WAN static IP, in advanced settings of WAN interface "use custom domain servers" and entered 8.8.8.8 and 8.8.4.4 are the only changes I made.
Lookup of mask.icloud.com from lan still does not work. Can lookup google.com, cannot lookup mask.icloud.com whether querying openwrt router or 8.8.8.8 directly.
I accept your suspicion of the comcast device but decline to do that. Another router/firewall (ubiquiti edgerouter) connected to the same comcast gateway can look up mask.icloud.com normally.
Confirm that there's nothing on the Mac that could be limiting this (obviously not the core OS, but an application or other policy laid on top)
That there is nothing in the Comcast configuration that could cause this issue.
Declining means we cannot explore these things. But, this is the first you've mentioned the ER -- is it configured the exact same way (from a functional standpoint, obviously it's a very different OS), such that it sits between the CBR2 and the Mac and has the same address on the WAN and same lan subnet?
Understood that help with my specific config ceases where I stop troubleshooting.
I have also tested this with an iphone and windows desktop on both networks.
The ubiquiti device is connected in the same logical order as the openwrt. I have not tried each of them with each other's IP addresses but my experience tells me there is not a difference there, they're on the same public subnet issued to me by comcast.
I believe I have recreated this to the point that I think others will find the same symptom in a fresh install, not that anyone is obligated to try it for me of course.
There is one scenario where this could be relevant (although it seems quite unlikely, but not impossible)...
If a system detected what it believes is abuse, it could shut down certain things. I wouldn't expect that here, given that you can use the same DNS server for other things. But, it could be worth trying, just to make sure that the problem follows the device, not the IP address.
(also, to be clear, I'm not saying you abused any services; abuse could be related to a previous user of the IP (if relevant) and/or false-positive triggers in the detection mechanisms).
Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
root@OpenWrt:~# cat /etc/config/firewall
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1
config zone
option name lan
list network 'lan'
option input ACCEPT
option output ACCEPT
option forward ACCEPT
config zone
option name wan
list network 'wan'
list network 'wan6'
option input REJECT
option output ACCEPT
option forward REJECT
option masq 1
option mtu_fix 1
config forwarding
option src lan
option dest wan
# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
option name Allow-DHCP-Renew
option src wan
option proto udp
option dest_port 68
option target ACCEPT
option family ipv4
# Allow IPv4 ping
config rule
option name Allow-Ping
option src wan
option proto icmp
option icmp_type echo-request
option family ipv4
option target ACCEPT
config rule
option name Allow-IGMP
option src wan
option proto igmp
option family ipv4
option target ACCEPT
# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
option name Allow-DHCPv6
option src wan
option proto udp
option dest_port 546
option family ipv6
option target ACCEPT
config rule
option name Allow-MLD
option src wan
option proto icmp
option src_ip fe80::/10
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family ipv6
option target ACCEPT
# Allow essential incoming IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Input
option src wan
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
list icmp_type router-solicitation
list icmp_type neighbour-solicitation
list icmp_type router-advertisement
list icmp_type neighbour-advertisement
option limit 1000/sec
option family ipv6
option target ACCEPT
# Allow essential forwarded IPv6 ICMP traffic
config rule
option name Allow-ICMPv6-Forward
option src wan
option dest *
option proto icmp
list icmp_type echo-request
list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
list icmp_type bad-header
list icmp_type unknown-header-type
option limit 1000/sec
option family ipv6
option target ACCEPT
config rule
option name Allow-IPSec-ESP
option src wan
option dest lan
option proto esp
option target ACCEPT
config rule
option name Allow-ISAKMP
option src wan
option dest lan
option dest_port 500
option proto udp
option target ACCEPT
### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
# option src lan
# option src_ip 192.168.45.2
# option dest wan
# option proto tcp
# option target REJECT
# block a specific mac on wan
#config rule
# option dest wan
# option src_mac 00:11:22:33:44:66
# option target REJECT
# block incoming ICMP traffic on a zone
#config rule
# option src lan
# option proto ICMP
# option target DROP
# port redirect port coming in on wan to lan
#config redirect
# option src wan
# option src_dport 80
# option dest lan
# option dest_ip 192.168.16.235
# option dest_port 80
# option proto tcp
# port redirect of remapped ssh port (22001) on wan
#config redirect
# option src wan
# option src_dport 22001
# option dest lan
# option dest_port 22
# option proto tcp
### FULL CONFIG SECTIONS
#config rule
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 80
# option dest wan
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp
# option target REJECT
#config redirect
# option src lan
# option src_ip 192.168.45.2
# option src_mac 00:11:22:33:44:55
# option src_port 1024
# option src_dport 80
# option dest_ip 194.25.2.129
# option dest_port 120
# option proto tcp