I think I destroyed my Xiaomi Mi Router AC2100

Hello Guys,
I think I screwed up and now I’ve disabled my router. :frowning:

I’ve tried several tutorials and I can’t get out of it, the router is with the blue lights on, but I can’t find it using any address, I use it as a router, because I have a modem from my Fiber Operator and I can only access internet because I activated wifi on this modem (is not very good the signal)..

The weird part is that I can access the router with ssh, connect my computer to the LAN port and when I enter the cable of the Modem, on the Xiaomi WAN, my PC connected to the Xiaomi, It connects to the internet... but I can’t access any router configuration pages ( or or show any Xiaomi WAN network.

I don’t know if I deleted the nvram or if I somehow did something stupid with the kernel, but is there a solution?

Do you mean you can't access a web interface on it? Because this...

suggests it is running.

What do you see when you open the SSH session? Is it an OpenWRT splash page?

Are you working your way through this? https://openwrt.org/toh/xiaomi/xiaomi_redmi_router_ac2100

I'd be cautious of playing with mtd until you've understood what is happening.

Thank you for your reply, when i access using ssh, i get this:

And mine, is the black one.. not the White... https://openwrt.org/toh/xiaomi/mi_router_ac2100?s[]=ac2100 this one

Hello Flollic,

How can I use this file? I just create a script inside the router and run it?

The BusyBox timestamp is today. Are you using snapshots or building yourself. The answer won't help me to help you, but it might inform someone else :slight_smile: .

I have tried configure using this documentation:

In fact, is the same instructions in the page that you mention...

Yes, I recognised the commands from there. Just making sure you were using that source and not a copy that might be a bit different elsewhere.

So you've followed the instructions from the top but the mtd commands aren't working?

My question about whether you're rolling your own firmware was because if you are but didn't include the kmod that frolic mentioned it could explain it. Or it may have been lost from the current snapshot build.

The instructions a bit further down may help you, and suggest it is not an entirely unexpected situation:

opkg install kmod-mtd-rw
insmod mtd-rw i_want_a_brick=1

It looks like the router is already running OpenWRT (so you have probably managed to correctly install it in the end) and since it looks like you have a snapshot build of OpenWRT, that also explains why you get internet but can't access the web interface (LuCi) since it's not included by default in snapshot builds. If you get internet through the router, you can try installing LuCi by running opkg update && opkg install luci after which you should be able to access the web interface normally on . To not lose web interface and any packages that you have installed, you can try using attended sysupgrade when upgrading to the newer snapshots.

Use sysupgrade to flash a new OpenWrt kernel + rootfs, which are packed together in a sysupgrade.bin file.

Do not run mtd directly to install upgrades.

Ok, i restored the router from the stock rom (chinese), i will try again do the install for openwrt.. but, at least i not destroyed the router as i think :stuck_out_tongue:

Voilá :smiley:

1 Like