I think I bricked my Linksys 3200ACM due to the FW Selector website

I was updating the FW on my Linksys WRT3200ACM and I guess funnily, if it doesn't have the "(Rango)" in the Device name, it will show a bunch of FW even if they are incompatible. So that is exactly what happened, I selected the Linksys WRT3200ACM (Rango), didn't see any updates past 19, deleted the Rango to retype it, then updates magically showed up. I thought it would mean they were compatible, since Linksys WRT3200ACM is in typed device selector list, but that is wrong and I feel like something should be fixed to prevent that.

But anyway, now I guess my router is a brick and I need to figure out a way to fix that, which I didn't plan on having to do. I have been trying the power-off method to return to a working FW slot but it doesn't seem to be working unfortunately. Any help would be appreciated.

I have tried holding reset for 30 seconds, unplugging, waiting 5 seconds, plugging power back in while holding reset and waiting 5 seconds, but the router still doesn't get detected over ethernet

That does nothing. There are no old-school eprom to clear by shorting.

That should work.
A sysupgrade only flashes one partition, so the other (the old firmware that you flashed from) should be still intact.

You forgot to mention, which firmware you are trying to upgrade from.

There have been lots of changes since the earliest WRT3200ACM days, and e.g. a sysupgrade compatibility verification has been introduced. But if you tried from 17.01 or similar, there was no check yet.

The network config has changes due to the DSA switch config intro, so if you kept your old config, that might be a reason for the "bricked" LAN connectivity.

But still, the the other, earlier, firmware partition should be intact. The power-off method should work, but may take several tries, so that you cut the power at the right moment.


Well I had old 18.0.06 or something and noticed it was years behind. So then I went to 19.0.X. And then to 21 and then 22 and then RC2. And the RC2 is when it never got back to LuciOpenWRT. It just doesn't work at all. 21 and 22 worked fine for reaching Luci, even though I know now the FW Device selector was being very misleading. But RC2 doesn't reach Luci at all. I will try the power off method more, thank you

Make sure you read the directions. Then read them again before you try it. Make sure you can see the lights on the router while you are performing the partition change. Timing is important.

1 Like

I have read it a few times and tried it a few times. I think I am just gonna try the USB TTL cable method to flash FW. The guide isn't very specific with the timing and I did it how the guide said. I would rather just solder up a cable and type a few commands, since it would be faster than trying every vague combination of flashing light + powering off.

Good luck!

1 Like

I thought I could solder up a USB cable, but apparently its not that simple. I will try the power off method a few more times and order a cable and everything should be fine hopefully, thank you.

Edit : I recorded a video with sound of pressing the switch with lights. Would anyone be able to tell me if it is too fast or too slow? - https://www.youtube.com/watch?v=XBUEkA2LRzM

I have tried it about 8 times with varying switching. I think the ethernet port just isn't working.

One of my rango did this “lost connectivity” thing. Tried the whole book of things to do but nothing worked. I ended up installing Linksys fw to get access again and then reinstall OpenWrt again.

Rango has a serial connector so you don’t need to solder, you just have to find the right Molex connector and cables with the right pins to connect to the PCB.

1 Like

Did you need a special cable? I tried making my own USB cable (nothing special) to connect to the pins and it didn't work. And now I bought a DEVMO PL2303TA USB to TTL RS232 COM UART Module Serial Cable Debug Console Adapter Compatible with Ar-duino,Raspberry Pi, but that is not working even though I matched up the correct COM port and bitrate. Idk if my own custom cable ruined the router, I didn't short anything though and I never played with any VCC.

Edit : checked cable with a multimeter, the white one is faulty and makes no contact. Will need to order another and try again

Yea, you need that also, if it works with Pi it will work with rango as far as the usb-to-ttl goes (and most other network equipment).

I mostly had in mind the solution for the physical connection to the PCB in the rango needs a molex connector with it’s tiny small pins. At least if you want meaningful steady contact.

1 Like

I think your a little too fast on the on/off. The idea is to interrupt the boot process 3 times to up the boot counter to 3 to force the other partition.

On switch on, the power and lan leds flash on. After all leds turn off, wait till the lan leds flash a second time and immediately switch off.

It can help on first attempts to go through the sequence 6 times to get the timing right rather than three on/off.

1 Like

I got the replacement cable today and followed a guide using TTFTP and Putty to setenv ipaddr, setenv serverip, setenv firmwareName and then did run update_both_images. Back to working OpenWRT on the latest 19 version.

Weirdly in this guide here - https://openwrt.org/toh/linksys/wrt3200acm
it shows the latest version is the 22.03.2, is that some kind of error? Because when selecting it from the dropdown, Rango disappears. Only when selecting the v19 FW's, does the router reappear in the firmware selector list.

WRT3200ACM builds are currently (since 22.03.3) disabled for 22.03.x as there is a major security flaw in the switch config.

See OpenWrt 22.03.3 third service release

mvebu: Disable devices using broken mv88e6176 switch. This affects the following devices (See mvebubroken_mv88e6176_switch , and #11077 ):

  • CZ.NIC Turris Omnia
  • Linksys WRT1200AC
  • Linksys WRT1900ACS
  • Linksys WRT1900AC v1
  • Linksys WRT1900AC v2
  • Linksys WRT3200ACM
  • Linksys WRT32X
  • Linksys WRT3200ACM
  • SolidRun ClearFog Pro

23.05 and main/master should be ok again, but if you upgrade to them, you should likely reconfig from scratch, just in case there is some incompatibility with your old config.


On that device when going from 19 to 21 or newer the config must be reset to default at upgrade since it got DSA from 21.02.


Hmmm, when I went from 18, to 19, 21, 22 and 23RC2, I never kept any settings between any flashes. And finally 23RC2 is what bricked my router, but neither 23.05.0 nor RC2 show as compatible for https://firmware-selector.openwrt.org/?version=19.07.4&target=mvebu%2Fcortexa9&id=linksys_wrt3200acm