I need help setting up a PPPoE connection

Hey there!

I'm very much a beginner and have just installed OpenWRT a couple of days ago.

I need help setting up PPPoE on this router, I have tried going to Network->Interface and adding a new interface with PPPoE but that gave me an error.

I also tried editing the WAN interface and changing the protocol from DHCP to PPPoE and adding the credentials, but that also didn't work.

I've uploaded a screenshot of the error I'm getting.

My ISP has provided me the PPPoE username, password, and a service name, I'm not sure what the service name is for.

If anyone could help me, that'd be greatly appreciated.

Router: DLink DIR-853 A3
OpenWRT Version: 21.02

I don't think that test123 interface is doing you any good here, it just raises the opportunity for things to go wrong - and be it 'just' that your ISP doesn't like two concurrent connections, work with wan alone.

If you haven't done much configuration with your router so far, it might help to start from a clean sheet - a factory reset, and then configuring wan for PPPoE with your username/ password. If that doesn't work out (even after a power down/ power up of the xDSL(?) modem), please paste the full /etc/config/network and only redact username/ password with xxx or similar.


Yes that is what you should do. Do not create a new interface.

The System Log will contain some messages about the attempted PPP connection. Authentication error could be because you need to register your router's MAC address with the ISP, or clone the MAC of your old router onto the wan interface.

1 Like

Thanks for the quick reply.

As per what you said, I've factory reset the router, configured WAN with the PPPoE credentials, and rebooted my modem. I'm still getting the same error, however.

I'm sorry if it's a stupid question but, where would I find this?

on OS level, need to connect to the device using ssh client, or winscp.

1 Like

Thanks, I'll upload the /etc/config/network right away.

1 Like

Here's my /etc/config/network file:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdc2:e036:3efa::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username 'xxxx'
	option password 'xxxx'
	option service 'xxxx'
	option ipv6 'auto'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

You do observe the error, correct?

"Auth To Peer Failed"

I would look at your credentials and verify they're correct.

I have double-checked, and I'm sure that they're correct. I have another router with me and the same credentials work with that one.

1 Like

Who is your ISP? Which country are you in?

It's a local ISP called Specificnet. I live in Mumbai, India

Try cloning the MAC address of the working router to the wan interface of the OpenWRT device.
Run these commands from the command line (copy/paste the whole block), but first set the correct MAC address.

uci add network device
uci set network.@device[-1].name='wan'
uci set network.@device[-1].macaddr='aa:bb:cc:dd:ee:ff'
uci commit network
/etc/init.d/network restart

This worked! Thanks!!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.