I have some ?s about OpenWrt wrt3200acm

I'm some what new to OpenWRT but I have worked with DD-WRT,debwrt & tomato.
my favorite Linux is Gentoo .

I have a Linksys wrt3200acm
When I got it I found out I could not install https://downloads.openwrt.org/releases/17.01.4/targets/mvebu/generic/lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-factory.img due to some install bug when going from Linksys-firmware to OpenWRT etc...
So I went with the https://downloads.openwrt.org/snapshots/targets/mvebu/cortexa9/openwrt-mvebu-cortexa9-linksys-wrt3200acm-squashfs-factory.img
and it worked & everything was happy & good
until a week later when I needed to install some kmod's & I suddenly realized that all the kmod's for my snapshot were gone. I know how Dev snapshots work
but I just did not think of this happening at the time of installing the snapshot.

So with that now we come to my 2 ?s:

When is the next stable update going to be?

.2 Now that I have OpenWRT installed can I just install /releases/17.01.4/targets/mvebu/generic/lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-sysupgrade.bin over my snapshot install.
It should be OK do that right?

  1. See ML
  2. If you could not install due to the updated flash on rango you will have to stay with a master image.

So then I have to move to the newest snapshot & grab the kmod’s I need before the next snapshot gen?

Are you sure I can't just take https://downloads.openwrt.org/releases/17.01.4/targets/mvebu/generic/lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-sysupgrade.bin & install it over my snapshot install?

Remember the problem I was having was with going from Linksys-firmware to OpenWRT with this one /releases/17.01.4/targets/mvebu/generic/lede-17.01.4-mvebu-linksys-wrt3200acm-squashfs-factory.img

The "snapshot" kernel modules are only "good" for a day -- until the next snapshot.

There should be a new "stable" release in the next month or so, but...

Since you've got Gentoo experience, it might be easy enough for you to build your own. On a modest box here, it takes under 30 min for a full OpenWRT, "clean" build. Building the toolchain the first time adds a little bit, but isn't painful. Upside includes not only having the ability to build the kernel modules you need when you want them, but also saving space by building in what you want to the flash; the squashfs system is xz compressed.


1 Like

If you were unable to install 17.04.1 due to the flash chip incompatibility with your new 3200, you need to stay with master. Support for new Winbond flash chips has not been backported to 17.01, I think. There is no that kind of difference in functionality between sysupgrade and factory versions that would eliminate the need for the flash chip support.

In addition, the wifi PCI names have changed in new kernels, so downgrading from master to 17.01 would mean some editing for wifi settings. Otherwise the configs are pretty compatible.

Hopefully there will be a new 18.06 major release in a month or so. That will be based on the current master, so it will support also try new 3200s.

1 Like

@jeff & @hnyman
Thank you so much for taking the time to reply back to me.:grinning:
Also @jeff thanks for the insight & maybe someday I will try & build it on my own but I work from home & just need my router to let me do my job more or less right now.
So I'm going to make a list📋 of all the kmod's I will need & upgrade to newest snapshot
then grab the kmod's & w8 for the next “stable” release (hopefully that will be soon)

For question 2, I think you can't.
Because your WRT3200ACM may use the new NAND flash that 17.01.4 doesn't support.
Better way is build all target def package by yourself and put them in some host machine.

Thank you for the info.

So I moved to the next snapshot
I went from 4.14.36-1 to 4.14.37-1
but now I have a new problem.
I can't install anything because there are no snapshot packages here
it's empty-> https://downloads.lede-project.org/snapshots/packages/arm_cortex-a9_vfpv3/
Where are the snapshot packages???!!!

I'm starting to get mad here
What I really want is a damn stable release!
but until the Dev people push one out I have to deal with this snapshot crap.
p.s. don't say build your own. I don't have time for that BS
I have soo many other things I need to be doing, that is not one of them.
This OpenWRT is getting in the way of me doing my Work!
So until the snapshot packages show up or I get a damn stable release
I'm screwed.
I'm living off my LTE cell phone tethering for now😒
but Where are the snapshot packages?

Calm down!

There were DNS problems yesterday (a server failed at a provider, from what I understand) and that may have impacted the build system. A quick check suggests that several builds didn't produce results. I have confidence that those with the "keys to the kingdom" are already aware of the build failures and are taking appropriate steps. Might be a day or two, depending on if it was just due to DNS, or also involving the "dead" hardware at the hosting service.

If you absolutely need the router NOW then you might be better served by the OEM software.

As an aside, you probably could have had your own build system up and running in the time you've spent. Even a "stable" branch could have had the same problems with builds and/or accessibility.

Coincidence that it happened just before the DNS outage, but a new pre-requisite for the build was introduced just before that. Now buildhosts need to have also "GNU time" package installed.

If a buildbot buildslave does not have that, the build fails. That failure was more visible with phase1 buildbot that makes the firmware images. @jow fixed at least some phase1 buildslaves. But it seems that also some phase2 buildslaves are failing the packages builds for the same reason.

The DNS outage kicked off the whole build farm in practice, so this prereq-based failure thing has been harder to notice than usually, as the build were failing for obvious DNS reasons for a while.

Once the buildslaves get "GNU time" host packages installed, things will return to normal. Hopefully.

Let me start with why I'm a bit pissed because my boss man is up my butt right now
because I am late with some work. I'm a Penetration Tester.

"If you absolutely need the router NOW then you might be better served by the OEM software."
I can't do that with the needs I have that's why I went with OpenWRT
but now I feel I should have put my $ into making a pfsense box🙄 vs. this Linksys wrt3200acm with OpenWRT

"you probably could have had your own build system up and running in the time"
I have never done that before with openWRT & there for I did not want to dick with it.
Am I a Dev? NO
do I want to be a OpenWRT Dev? hell no

Well it looks like I'm going to have plug in my laptop into the cable modem
& do a Windows 7 Internet connection share to my Gentoo server & Kali Linux laptop.
Fun fun

One thing you can do is try a build from @davidc502 (https://davidc502sis.dynamic-dns.net/). He does occasional builds of snapshots and hosts them along with their packages for an extended period.

I do agree though, we really do need a stable release sometime soon (a lot has changed since LEDE 17).

lol Malwarebytes is blocking -> https://davidc502sis.dynamic-dns.net/
I will look into it later
I'm almost done with setting up Windows 7 Internet connection share with my Linux laptop & Linux server
I need a for-sure thing at this point in time & not more OpenWRT "maybes".
I have had to setup Win ICS with Linux this before when my old router died in March.

To the head OpenWRT people:
If I don't see a stable release of OpenWRT with in the next month
I will give up on OpenWRT, move to pfsense & tell anyone to stay far away from openwrt & go with pfsense. Stop dicking around & release something already!!!!

If it tides you over, there are wrtpac images off the link on my avatar; note, no ppp in base image.

If you need OpenWRT for employment purposes...and you need snapshot instead of the 17.01.4 stable release, you may wish to build custom firmware for your device, or have a server copy all packages for a given snapshot and CPU target, in case you need them at a future time.

Another user in this forum solved a similar issue in this manner.

@anomeome Thanks but I am done with setting up Win 7 ICS everything is running without the router now
So now I can get to work.

"and you need snapshot instead of the 17.01.4 stable release"
No I did not need a snapshot....
The lame 2017 stable release would not install on wrt3200acm going from Linksys-firmware to OpenWRT.
So I had to install the blah snapshot🙄

1 Like

I have been looking at the cost of making my own pfSense box
I paid $216 for Linksys wrt3200acm router.
For $290 I could make my own pfsense box.
Running a 3rd Gen Intel Core i3 3.3GHz with 8GB of DDR3 RAM & a 250GB 7,200 rpm HD,
Intel EXPI9404PT PCI-Express PRO/1000 PT Quad Port Ethernet Server Adapter
& a Rosewill RNX-AC1900PCE or a ASUS PCE-AC56 PCIe Wi-Fi Adapter. (still thinking on wifi)
So with a bit mo $ I get way better hardware & I can install a better OS (pfSense)
I'm within my return window for the wrt3200acm, so that's what I'm going to do because yes I like OpenWRT​:+1: but I don't like what I'm seeing from how this project is ran......:disappointed:
The pfSense team looks like they know where they are going & OpenWRT team looks like a kid who lost his mom in the mall.:roll_eyes:
I'm hardcore disappointed from what I'm seeing from the OpenWRT team.:disappointed:

Hi if you are going down that root then I would go with opensense.
Better then pfsense IMO. The 17.1.4 build not installing over the stock fermwair is not the falt of openwrt it is because the OEM changed the flash chips in the newer wrt3200ac routers after the 17.1.4 fermwair was put out. I have bin using openwrt for years now and never have i seen the packages not build. I am sorry about your trubbles!

1 Like