I have a bricked TP-Link 1043N V5 at my desk. Help?

I remember how I bricked it, so if that helps ..

I downloaded the factory images for my TP-Link 1043N V5 and tried to use the sysupgrade command with it. When I got errors, I did this -

# cd /tmp
/tmp # mtd -r openwrt-18.06.1-ar71xx-generic-tl-wr1043n-v5-squashfs-factory.bin firmware

Right now, I'm only getting a light on the power LED and nothing else. If I reboot the router, the power LED blinks only once and then stays on without blinking. I'm not seeing any other light on any other LED.

I wasn't able to enter the failsafe mode and I tried using the reset button but that isn't helping either. Pressing the reset button at boot just switches on the last LED (with two arrows on either direction) for a few seconds and then the power LED is the only LED that is on.

Can this router be saved without opening it?

Have you already tried this?

Rename original TP-Link firmware with WR1043v5_tp_recovery.bin and flash by Tftp server.

@tmomas @shayo7 That guide uses Windows but I'm using Linux.

Sorry, but I don't know what I'm missing. I installed tftp-hpa and started a tftp server using

$ in.tftpd -L --address -s /tftpboot/

/tftpboot is owned by the user with 777 permissions and I've kept the file in it with the original name as downloaded. However, after running that command, I'm unable to see a process with that name using htop or ps command.

I restarted my router while pressing the reset button using a pen and the router just started with a single blink in power and staying on and few seconds of the last LED being on. I see nothing else.

I downloaded the original TP-Link firmware and renamed it to WR1043v5_tp_recovery.bin and kept in /tftpboot with 777 permissions and nobody ownership.

After that I started the tftp server using -

$ in.tftpd -L --address -s /tftpboot/

I also assigned the static IP to my ethernet device.

I restarted the router while pressing the reset button but I got nothing different. The router just shows the power LED and the last LED switches on for maybe 5 seconds and then nothing.

Use wireshark to see what's going on during your attempt to flash via tftp.

Wireshark shows no activity on enp3s0.

I know that I have things working on my desktop. The tftp server has started successfully. I'm able to use the tftp client on my desktop to get the firmware that I'm trying to serve. I've assigned the static IP of the host as The router is connected to the PC via LAN and not WAN.

EDIT: I've also disabled the iptables.service if that's of any concern.

I'm stuck. :worried:

I had the same problem with v4 (same board), it turned out you had to press reset button not before power on but just after power on, a slight delay, tftpd should print a log with requested file

Sorry, but that didn't work either. I'm getting the same reaction no matter what I do. The power LED stays on without blinking (except once) and no other LED blinks or switches on. The last LED lights up for about 3-5 seconds when I press the reset button at the start but that's it.

Did you disable the firewall?


If it helps, this is the list of all the commands that I've run on my desktop.


Can you tail the logs of the TFTP Server? See if the router is actually trying to connect after following the steps while powering on and if so the filename it is requesting is correct.

The logs of the tftpd.service contains nothing except the time when the service was started and stopped. Should I started the in.tftpd command again with the "verbose" parameter?

I suspect that the router isn't connecting to the TFTP server for some reason. I followed the same steps mentioned in the link above in a live USB of Ubuntu but I had the same results.

Have you checked for ARP requests?

Certain versions of TP-Link devices look for different addresses than the typical, such as

I still think that the timing is not good, maybe you can also try the wan port. last option is the serial cable, I think you'll have to connect a missing resistor

It certainly would not hurt to try that.

As @lucize stated about the timing too, it can be really tricky and take quite a few times of trial and error to get it right.

Maybe try following the steps in this article to see if you can reach the router in failsafe mode:

Then reflash OpenWrt ("sysupgrade" not "factory") on it if you can reach failsafe.

For future reference, openwrt-xxx-factory.bin files are used only for flashing from stock firmware to OpenWrt, not reverting back to stock firmware or upgrading. So if you are able to get in to failsafe mode and get OpenWrt working on it again and wish to revert back to stock firmware, you will want to download the stock firmware off TP-Link's website for your TL-WR1043N V5. SCP that firmware to the /tmp directory of your router. Then SSH in to the router and run the following commands:

  1. cd /tmp
  2. dd if=<stock_firmware_image> of=tplink.bin skip=257 bs=512
    (In order to flash the TL-WR1043N/ND series stock firmware we need to strip the uboot image off it when flashing it under OpenWrt)
  3. mtd -r write tplink.bin firmware
    (Write the stripped firmware)

New URL: https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset#failsafe_mode

The old page is for archival purposes only and does not receive updates any more.

Go through the site tmomas posted and get a clue what is possible.
First disconnect all network adapters/cables from your system.
Install tcpdump. On debianlike distribution with
apt-get update && apt-get install tcpdump
then go on with - on old debain
change $INTERFACE to your interface

ifconfig $INTERFACE down
ifconfig $INTERFACE up
ifconfig $INTERFACE

on new debain

ip link set $INTERFACE up
ip addr add dev $INTERFACE

dont mess with netmask just give that a try:
start tcpdump
tcpdump -i $INTERFACE
start your router and press the reset button keep it pressed for 15 seconds and
read the output, you'll hopefully see the ipadress of your router asking for tftp then stop tcpdump with ctrl+c .. try to start the server with verbose output
read about it in
tftpd --help
i never use original firmware from tplink to debrick i always use the openwrt-***-factory.bin it should work if your router is compatible, so you dont have to mess around with dd.
Does the LAN LED of your router switch on when you insert the rj45-cable? Does ifconfig gives you a Scope:Link ?
Or try out
ip link to see if the network card has a physical connection to your router.
Your router will restart if he could'nt find the tftpd server tcpdump is usefull to see the timespan you have. And if the router actually boots to recovery.

good luck

@lucize What should I watch out for? I guess there would be a timing issue if it were possible for the router to go to failsafe mode but that isn't possible right now because the power LED doesn't blink. It just stays on as soon. If I press a reset button before powering on the router and keep pressing the reset button, the last LED lights up (without blinking) for maybe 5 seconds and then that goes away as well along with a single blink on the power LED. This happens even if I press the reset button after a second of starting the router.

@mj5030 Using the --verbose flag gave me nothing different.

@mj5030 Like I said before, I don't think that going into the failsafe mode is possible because the power LED doesn't blink ... at all.

@eliasmagnus Thanks for the help. However, I didn't see any output in either Wireshark or tcpdump. I tried connecting my Ethernet cable to both the LAN and WAN port and used both and No output. Nothing.