I have 2 identical devices, one of them bricked

I want to recover the brick with the functional
In the functional device I run

cat /proc/mtd

And I got this

mtd0: 01000000 00010000 "ALL"
mtd1: 00030000 00010000 "Bootloader"
mtd2: 00010000 00010000 "Config"
mtd3: 00010000 00010000 "Factory"
mtd4: 007b0000 00010000 "firmware1"
mtd5: 00664e4f 00010000 "rootfs"
mtd6: 00160000 00010000 "rootfs_data"
mtd7: 007b0000 00010000 "firmware2"
mtd8: 00050000 00010000 "reserved"

It has a MT7628, and I have tried

cat /dev/mtd4 > /tmp/firmware.bin  ==> The brick wake up but doesnt work LTE

dd if=/dev/mtd4 of=/tmp/firmware.bin  ==> Same that previous

cat /dev/mtd4 > /tmp/firmware.bin
cat /dev/mtd7 >> /tmp/firmware.bin  ==> The brick falls into boot loop

cat /dev/mtd0 > /tmp/firmware.bin  ==> The brick starts even with the same SSID 
than the functional device but still LTE does not work

I have tried flash the brick with uboot and mtd -r write /tmp/firmware.bin
Both of them have the same baseband

I will thank you so much

An LTE modem is usually an independent subsystem with its own firmware-- its only connection to the MT7628 processor running OpenWrt is a USB bus.

If you did copy ALL from one unit to the other (which is not recommended, since that clobbered unit-specific data in the factory partition like wifi calibration and MAC addresses), they should run the same and you should use the running OpenWrt to troubleshoot the modem.

Maybe the LTE card is dead. Try swapping them?

Maybe the LTE card has a loose antenna connector?

Maybe reseating the LTE card will bring it back to life?

The LTE card does not work since I tried an update
With original firmware it worked

This doesn't look right, unless it's a typo.

cat /dev/mtd7 >> /tmp/firmware.bin

HOLA GABO buen dia, tienes el mismo router 4g h3s, ando en las mismas quiero preguntarte si ya pudiste montarle el openwrt y si te funciona bien, muchas gracias por tu colaboracion, un abrazo...

HELLO GABO good day, you have the same 4g h3s router, I'm in the same I want to ask you if you were able to mount the openwrt and if it works well for you, thank you very much for your collaboration, a hug...

The preferred language in the OpenWrt forum is english.
When writing in your native language, please always provide an english translation.
This way other users all around the world can take part in the discussion and possibly benefit from the outcome, without having to use a translator.

Thanks! :slight_smile: