I got wifi problem with openwrt 24.10.stable

My device: Phicomm k2g
I only enable 5g signal,
after some times, I lost signal completely.
Restart radio0 or disable and enable ssid not work.
I have to reboot the router device.

logs:

Fri Feb 14 13:31:55 2025 kern.info kernel: [  858.032745] mt76x2e 0000:01:00.0: Firmware Version: 0.0.00
Fri Feb 14 13:31:55 2025 kern.info kernel: [  858.043768] mt76x2e 0000:01:00.0: Build: 1
Fri Feb 14 13:31:55 2025 kern.info kernel: [  858.051974] mt76x2e 0000:01:00.0: Build Time: 201607111443____
Fri Feb 14 13:31:55 2025 kern.info kernel: [  858.073703] mt76x2e 0000:01:00.0: Firmware running!
Fri Feb 14 13:31:55 2025 kern.info kernel: [  858.086606] ieee80211 phy0: Hardware restart was requested
Fri Feb 14 13:32:44 2025 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED 76:ee:02:a4:06:90
Fri Feb 14 13:32:44 2025 daemon.info hostapd: phy0-ap0: STA 76:ee:02:a4:06:90 IEEE 802.11: disassociated
Fri Feb 14 13:32:45 2025 daemon.info hostapd: phy0-ap0: STA 76:ee:02:a4:06:90 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Fri Feb 14 13:36:56 2025 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED 12:ad:52:cd:ff:18
Fri Feb 14 13:36:56 2025 daemon.info hostapd: phy0-ap0: STA 12:ad:52:cd:ff:18 IEEE 802.11: disassociated
Fri Feb 14 13:36:57 2025 daemon.info hostapd: phy0-ap0: STA 12:ad:52:cd:ff:18 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
root@OpenWrt:~# ubus call system board
{
        "kernel": "6.6.73",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7620A ver:2 eco:6",
        "model": "Phicomm K2G",
        "board_name": "phicomm,k2g",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "ramips/mt7620",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd43:0e5e:3f14::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '98:bb:99:4c:e8:53'

config interface 'wan'
        option device 'eth0.2'
        option proto 'pppoe'
        option username 'xxxxxxxxxx'
        option password 'xxxxxx'
        option ipv6 'auto'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

config route
        option interface 'lan'
        option type 'anycast'
        option target '192.168.1.1/24'
        option gateway '192.168.2.1'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '161'
        option band '5g'
        option cell_density '2'
        option country 'CN'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'wifi.imever.me'
        option encryption 'psk-mixed'
        option key 'xxxxxxxxx'
        option hidden '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option disabled '1'
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name 'www.imever.me'
        option ip '2001:19f0:xxxxxxxxxxxxxx'
root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config ipset
        option name 'gfwlist6'
        option comment 'firewall'
        option family 'ipv6'
        list match 'dest_ip'

Let's review the config to ensure there aren't any issues that might be causing this:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thanks.
I already updated my topic with more information

This route looks wrong:

Where is 192.168.1.0/24?

Remove the cell density:

Don't use psk-mixed, select WPA2 (psk2) instead. Also, hiding your SSID doesn't improve security, so remove that option.

Restart and test again.

Thanks for your suggestion.
I will try it later.

Not work.
When I back my phone, it upload large data, the wifi crash very soon.
Only browser, it seams ok.

Do you have the same issue with 23.05?
The Phicomm k2g is an 8/64 device and we are very close to the end of support for that configuration.
I see that your Phicomm k2g is also a PPPoE client which is quite CPU and memory intensive.

NO,never happened with 23.05.
I notice this happened when I backup my phone data to server.
So upload large data will trigger this error.
Just browser web and watch video seams good.

1 Like

I got the same problem.

After upgrade from 23.05.5 to the latest release,

https://downloads.openwrt.org/releases/24.10.0/targets/ramips/mt7621/openwrt-24.10.0-ramips-mt7621-d-team_newifi-d2-squashfs-sysupgrade.bin,

any heavy load use case will result in 5G wifi down and SSID disappear. Even just browsing and chatting, the problem will finally happen in arround 24 hrs, while 2G wifi and wire still accessible.

ssh command - wifi restart does no help. luci "wireless, restart" will return an error like "device not available". Only reboot will bring the 5G wifi back.

Since all settings are proven OK in 23.05.5 and as stable use in months, I have to roll back to it.

Could anyone know the reason? There are many changes with the new kernel.

Thanks

3 Likes