I found an old AP Ocedo Koala, how do I install/ flash openwrt?

I found an old AP Ocedo Koala in my old stuff. along with riverbed DTAFA.
It's from my former employer. They don't use it any more since they switched to Meraki years ago. It just occurred to me that I might revitalise it with openwrt and looked it up. Sure enough it's supported:
https://openwrt.org/toh/hwdata/ocedo/ocedo_koala
riverbed one isn't listed.
I plugged the ocedo one in and resetted it via 10s button.
It gets an 192.168. IP and in wireshark I could see traffics like NTP, DNS requests for ocedo.cc and riverbed.cc, TLS handshake and TCP packets with TLS encryption etc. But I can't see the Web UI like in manual: https://fccid.io/2AAUY-KOALA/User-Manual/User-Manual-rev-pdf-2459872
the IP is pingable
I also don't see a serial port.
any one knows how to work with devices like this?

There appear to be installation instructions in the git commit:

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=e36f8b3f3980903d5cefc51fe274c19c7a0719f2

Try following those.

1 Like

Thank you so much.

I see in wireshark AP is requesting via TFTP koala-uimage-factory from 192.168.100.8

TFTP service that I started in docker and wsl seem to be an issue, I'll try with ubuntu VM tomorrow.

just to confirm that the ramdisk image mentioned in the commit message, is it this one? https://downloads.openwrt.org/releases/23.05.0/targets/ath79/generic/openwrt-23.05.0-ath79-generic-ocedo_koala-squashfs-sysupgrade.bin

I never used sysupgrade, so what is expected of "OpenWRT can be written to the flash via sysupgrade or mtd."?

It's not, you can find both images in https://downloads.openwrt.org/releases/23.05.0/targets/ath79/generic/.

Sysupgrade is a command for upgrading/installing Openwrt.

Download both images from here:
https://firmware-selector.openwrt.org/?version=23.05.3&target=ath79%2Fgeneric&id=ocedo_koala

Rename the "...initramfs-kernel.bin" image to "koala-uimage-factory" and let the AP boot it via TFTP.

Then transfer the "..squashfs-sysupgrade.bin" bin to your router and use the sysupgrade command to install it:

scp openwrt-23.05.3-ath79-generic-ocedo_koala-squashfs-sysupgrade.bin root@192.168.1.1:/tmp

ssh root@192.168.1.1

sysupgrade -n /tmp/openwrt-23.05.3-ath79-generic-ocedo_koala-squashfs-sysupgrade.bin

21 and 22 worked for TFTP boot

I also needed to run: fw_setenv bootcmd run bootcmd_1

before I run: sysupgrade -n /tmp/openwrt-22.03.6-ath79-generic-ocedo_koala-squashfs-sysupgrade.bin

I upgraded later to latest 23 via web.

I also have a riverbed SDI-AP5-B020, FCC-ID: ZHV-DTAFA looks exactly the same as Koala, it's not supported by openwrt, but I could boot with the same initramfs-kernel.bin

it's ok if I brick it but it never hurts to ask first :D.

is it ok if I use the same initramfs-kernel.bin and sysupgrade as Koala? Or should I compile my own firmware?

I tried to start with u-boot but didn't know which config to choose.

screenshot below is from riverbed SDI-AP5-B020 with initramfs-kernel 22.03.6

we have an amazing community here. :heart_on_fire:

2 Likes

They look quite similar, yes.
It looks like Riverbed took over Ocedo and reused the design.
What looks different from the FCC pictures is the 5GHz card they used.
Sadly the exact chip is not visible, covered by a thermal pad.
I'm also missing the second radio from your screenshot,
only the SOC's 2.4GHz radio is shown.

If you are interested, let's open a new topic for it.

We should investigate first and try to collect as much information as possible.
Once you flash OpenWrt on it, some information could be lost, like the original flash layout.

The ODM for both devices looks to be Senao. There's bunch of clones already supported by OpenWrt.
Anyway, before flashing random firmware make sure partition layout is same, otherwise sysupgrading from initramfs could overwrite crucial data, like bootloader or wireless calibration data. To get the partition layout check kernel log or run cat /proc/mtd on the Riverbed running original firmware. Also check bootloader booting command if it's loading from proper flash memory offsets.

2 Likes

The is a new topic for investigation of support for the Riverbed AP...

yes, I created it per your suggestion.

thx, I'll follow up in my other topic

1 Like