I dont know what i did to my Sagem 2604 (4 MB flash, 16 MB RAM)

Hello, i flashed the http://downloads.openwrt.org/releases/18.06.2/targets/brcm63xx/generic/openwrt-18.06.2-brcm63xx-generic-FAST2604-squashfs-cfe.bin to the router using the web of the router, and after that now i have switch. Its normal? there any way to acces it to use the wifi or restore it back to normal. Thanks

No, it's normal to have access to the device at 192.168.1.1 - per the instructions.

So, since It's not clear what you mean here, as a lot of devices act as a dumb switch if they're bricked...Can you look at the serial console?

  • Did you power off the device during flashing?

Hi, thanks for the answer. I wait until the router restarted, and then tried some configurations of ips to try to connect to the router. then i restarted it.

BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.2, r7676-cddd7b4c77
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:/#
root@OpenWrt:/#

this is what say in the serial console

Sagem CFE version: 3.43
Build Date: Thu Jun 25 17:51:50 CST 2009 (chenc@svr1.sagem-szn.com)
Copyright (C) 2005-2006 Sagem communication.

Boot Address 0xbfc00000

Initializing Arena.
Initializing Devices.
Parallel flash device: name SST39VF3201, id 0x235b, size 4096KB
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:25:69:a1:65:fe, BoardId=F@ST2604
getShareBlks: i=1010, sect_size=4096, end_blk=1016
getShareBlks: i=1011, sect_size=4096, end_blk=1016
getShareBlks: i=1012, sect_size=4096, end_blk=1016
getShareBlks: i=1013, sect_size=4096, end_blk=1016
getShareBlks: i=1014, sect_size=4096, end_blk=1016
getShareBlks: i=1015, sect_size=4096, end_blk=1016
Backup content:[<psitree>
]
getShareBlks: i=1018, sect_size=4096, end_blk=1024
getShareBlks: i=1019, sect_size=4096, end_blk=1024
getShareBlks: i=1020, sect_size=4096, end_blk=1024
getShareBlks: i=1021, sect_size=4096, end_blk=1024
getShareBlks: i=1022, sect_size=4096, end_blk=1024
getShareBlks: i=1023, sect_size=4096, end_blk=1024
PSI content:[▒▒▒▒▒▒▒▒▒▒]
Reset  mii_switch_unmanage_mode configuration
CPU type 0x29107: 256MHz, Bus: 128MHz, Ref: 32MHz
Total memory: 16777216 bytes (16MB)

Total memory used by CFE:  0x80401000 - 0x8052A990 (1218960)
Initialized Data:          0x8041E2D0 - 0x80421100 (11824)
BSS Area:                  0x80421100 - 0x80428990 (30864)
Local Heap:                0x80428990 - 0x80528990 (1048576)
Stack Area:                0x80528990 - 0x8052A990 (8192)
Text (code) segment:       0x80401000 - 0x8041E2CC (119500)
Boot area (physical):      0x0052B000 - 0x0056B000
Relocation Factor:         I:00000000 - D:00000000

Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:25:69:a1:65:fe, BoardId=F@ST2604
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:25:69:a1:65:fe, BoardId=F@ST2604
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:25:69:a1:65:fe, BoardId=F@ST2604
Board IP address                  : 192.168.1.1:ffffff00
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash (f)                : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:25:69:a1:65:fe, BoardId=F@ST2604
Board Id (0-9)                    : F@ST2604
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : 00:25:69:a1:65:fe
PSI Size (1-64) KBytes            : 24
Customer Name (0-4)               : 4

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
Enter kerSysNvRamGet(CFE)
getShareBlks: i=0, sect_size=4096, end_blk=1
kerSysNvRamGet(CFE) Mac address:00:25:69:a1:65:fe, BoardId=F@ST2604
Code Address: 0x80A00000, Entry Address: 0x80a00000
Booting from image (0xbfc10000) ...
Decompression OK!
Entry at 0x80a00000
Closing network.
Starting program at 0x80a00000
[    0.000000] Linux version 4.9.152 (buildbot@7befac494a11) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7676-cddd7b4c77) ) #0 Wed Jan 30 12:21:02 2019
[    0.000000] Detected Broadcom 0x6348 CPU revision b0
[    0.000000] CPU frequency is 256 MHz
[    0.000000] 16MB of RAM installed
[    0.000000] board_bcm963xx: Boot address 0xbfc00000
[    0.000000] board_bcm963xx: CFE version: 0.51.46-52.51
[    0.000000] bcm63xx_nvram: nvram checksum failed, contents may be invalid (expected 77d6959a, got 9ebed406)
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00029107 (Broadcom BMIPS3300)
[    0.000000] board: board name: F@ST2604
[    0.000000] MIPS: machine is Sagem F@ST2604
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 01000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
[    0.000000] Primary data cache 8kB, 2-way, VIPT, no aliases, linesize 16 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000000ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000000ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000000ffffff]
[    0.000000] Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 4064
[    0.000000] Kernel command line: rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 64 (order: -4, 256 bytes)
[    0.000000] Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Memory: 10320K/16384K available (3509K kernel code, 179K rwdata, 576K rodata, 1296K init, 209K bss, 6064K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=16, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 14931722236 ns
[    0.000043] sched_clock: 32 bits at 128MHz, resolution 7ns, wraps every 16777215996ns
[    0.008321] Calibrating delay loop... 254.46 BogoMIPS (lpj=508928)
[    0.047320] pid_max: default: 32768 minimum: 301
[    0.052720] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.059747] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.089678] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.099993] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.106775] pinctrl core: initialized pinctrl subsystem
[    0.120100] NET: Registered protocol family 16
[    0.137878] Can't analyze schedule() prologue at 80379c54
[    0.143879] registering PCI controller with io_map_base unset
[    0.149958] registering PCI controller with io_map_base unset
[    0.264430] PCI host bridge to bus 0000:00
[    0.268903] pci_bus 0000:00: root bus resource [mem 0x30000000-0x37ffffff]
[    0.276180] pci_bus 0000:00: root bus resource [io  0x8000000-0x8007fff]
[    0.283265] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.290439] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.307793] pci 0000:00:01.0: BAR 0: assigned [mem 0x30000000-0x30001fff]
[    0.316352] PCI host bridge to bus 0000:01
[    0.320841] pci_bus 0000:01: root bus resource [mem 0x38000000-0x3fffffff]
[    0.328111] pci_bus 0000:01: root bus resource [io  0x8008000-0x800ffff]
[    0.335198] pci_bus 0000:01: root bus resource [??? 0x00000000 flags 0x0]
[    0.342373] pci_bus 0000:01: No busn resource found for root bus, will use [bus 01-ff]
[    0.351923] pci 0000:01:1e.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.361448] pci 0000:01:1e.0: BAR 10: assigned [mem 0x38000000-0x3fffffff]
[    0.368791] pci 0000:01:1e.0: BAR 7: assigned [io  0x8008000-0x80080ff]
[    0.375817] pci 0000:01:1e.0: BAR 8: assigned [io  0x8008400-0x80084ff]
[    0.382827] pci 0000:01:1e.0: CardBus bridge to [bus 02-05]
[    0.388741] pci 0000:01:1e.0:   bridge window [io  0x8008000-0x80080ff]
[    0.395742] pci 0000:01:1e.0:   bridge window [io  0x8008400-0x80084ff]
[    0.402745] pci 0000:01:1e.0:   bridge window [mem 0x38000000-0x3fffffff]
[    0.434933] clocksource: Switched to clocksource MIPS
[    0.447848] PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
[    0.488170] ssb: Found chip with id 0x4318, rev 0x02 and package 0x00
[    0.539245] ssb: WARNING: Using fallback SPROM failed (err -2)
[    0.547687] ssb: Failed to register PCI version of SSB with error -2
[    0.555140] b43-pci-bridge: probe of 0000:00:01.0 failed with error -2
[    0.563684] NET: Registered protocol family 2
[    0.572978] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.580595] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.587473] TCP: Hash tables configured (established 1024 bind 1024)
[    0.595317] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.601684] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.609691] NET: Registered protocol family 1
[    0.624513] Crashlog allocated RAM at address 0xf00000
[    0.639364] workingset: timestamp_bits=30 max_order=12 bucket_order=0
[    0.682358] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.688616] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.781831] io scheduler noop registered
[    0.786101] io scheduler deadline registered (default)
[    0.798764] bcm6348-pinctrl fffe0400.pin-controller: registered at mmio fffe0400
[    0.812067] fffe0300.serial: ttyS0 at MMIO 0xfffe0300 (irq = 10, base_baud = 1562500) is a bcm63xx_uart
[    0.822106] console [ttyS0] enabled
[    0.822106] console [ttyS0] enabled
[    0.829461] bootconsole [early0] disabled
[    0.829461] bootconsole [early0] disabled
[    0.843552] 1fc00000.nor: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x0000bf Chip ID 0x00235b
[    0.854127] number of CFI chips: 1
[    0.891411] bcm63xxpart: nvram checksum failed, contents may be invalid (expected 77d6959a, got 9ebed406)
[    0.901488] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000
[    0.908297] bcm63xxpart: Partition 1 is nvram offset 3f0000 and length 10000
[    0.915732] bcm63xxpart: Partition 2 is linux offset 10000 and length 3e0000
[    0.923205] 3 bcm63xxpart partitions found on MTD device 1fc00000.nor
[    0.930009] Creating 3 MTD partitions on "1fc00000.nor":
[    0.935689] 0x000000000000-0x000000010000 : "CFE"
[    0.949233] 0x0000003f0000-0x000000400000 : "nvram"
[    0.965533] 0x000000010000-0x0000003f0000 : "linux"
[    0.983803] parser_imagetag: rootfs: CFE image tag found at 0x0 with version 6, board type F@ST2604
[    0.993421] parser_imagetag: Partition 0 is kernel offset 100 and length 15d7ac
[    1.001127] parser_imagetag: Partition 1 is rootfs offset 15d8ac and length 282754
[    1.009101] parser_imagetag: Spare partition is offset 3a0004 and length 3fffc
[    1.016752] 2 bcm963xx-imagetag partitions found on MTD device linux
[    1.023482] Creating 2 MTD partitions on "linux":
[    1.028581] 0x000000000100-0x00000015d8ac : "kernel"
[    1.043835] 0x00000015d8ac-0x0000003e0000 : "rootfs"
[    1.060630] mtd: device 4 (rootfs) set to be root filesystem
[    1.066786] 1 squashfs-split partitions found on MTD device rootfs
[    1.073394] 0x00000039f000-0x0000003e0000 : "rootfs_data"
[    1.100375] bcm63xx-spi fffe0c00.spi: at [mem 0xfffe0c00-0xfffe0c3f flags 0x200] (irq 9, FIFOs size 63)
[    1.116205] libphy: Fixed MDIO Bus: probed
[    1.149408] libphy: bcm63xx_enet MII bus: probed
[    1.154791] Generic PHY bcm63xx_enet-1:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=bcm63xx_enet-1:00, irq=-1)
[    1.168234] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    1.185989] NET: Registered protocol family 10
[    1.222230] NET: Registered protocol family 17
[    1.227423] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.241027] 8021q: 802.1Q VLAN Support v1.8
[    1.251178] random: fast init done
[    1.274336] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    1.311874] Freeing unused kernel memory: 1296K
[    1.316747] This architecture does not have kernel memory protection.
[    2.901422] init: Console is alive
[    2.906312] init: - watchdog -
[    4.828320] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    5.057706] bcm6348-pinctrl fffe0400.pin-controller: pin gpio33 already requested by fffe0400.pin-controller; cannot claim for bcm63xx-gpio.1:476
[    5.071477] bcm6348-pinctrl fffe0400.pin-controller: pin-33 (bcm63xx-gpio.1:476) status -22
[    5.080322] gpio-keys-polled gpio-keys-polled: unable to claim gpio 476, err=-22
[    5.088205] gpio-keys-polled: probe of gpio-keys-polled failed with error -22
[    5.101374] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    5.120725] init: - preinit -
[    8.034007] random: jshn: uninitialized urandom read (4 bytes read)
[    8.440204] random: jshn: uninitialized urandom read (4 bytes read)
[    9.177963] random: jshn: uninitialized urandom read (4 bytes read)
[    9.371162] random: jshn: uninitialized urandom read (4 bytes read)
[    9.736339] random: jshn: uninitialized urandom read (4 bytes read)
Failed to connect to the switch. Use the "list" command to see which switches are available.
Failed to connect to the switch. Use the "list" command to see which switches are available.
Failed to connect to the switch. Use the "list" command to see which switches are available.
Failed to connect to the switch. Use the "list" command to see which switches are available.
[   10.763384] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   14.780429] mount_root: no usable overlay filesystem found, using tmpfs overlay
[   14.877951] urandom-seed: Seed file not found (/etc/urandom.seed)
[   15.237049] procd: - early -
[   15.240807] procd: - watchdog -
[   16.229088] procd: - watchdog -
[   16.234450] procd: - ubus -
[   16.469931] random: ubusd: uninitialized urandom read (4 bytes read)
[   16.666275] random: ubusd: uninitialized urandom read (4 bytes read)
[   16.674908] random: ubusd: uninitialized urandom read (4 bytes read)
[   16.689043] procd: - init -
Please press Enter to activate this console.
[   18.093575] kmodloader: loading kernel modules from /etc/modules.d/*
[   18.303835] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   18.360780] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[   18.369276] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[   18.388839] ip_tables: (C) 2000-2006 Netfilter Core Team
[   18.431451] nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
[   18.655342] xt_time: kernel timezone is -0000
[   19.124694] PPP generic driver version 2.4.2
[   19.141461] NET: Registered protocol family 24
[   19.557398] Broadcom 43xx driver loaded [ Features: PNL ]
[   19.599122] kmodloader: done loading kernel modules from /etc/modules.d/*
[   53.399268] random: crng init done
[   53.402786] random: 2 urandom warning(s) missed due to ratelimiting
[  123.984517] br-lan: port 1(eth0) entered blocking state
[  123.990149] br-lan: port 1(eth0) entered disabled state
[  123.997300] device eth0 entered promiscuous mode
[  124.243797] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[  142.275234] jffs2_scan_eraseblock(): End of filesystem marker found at 0x1000
[  142.291144] jffs2: Cowardly refusing to erase blocks on filesystem with no valid JFFS2 nodes
[  142.300051] jffs2: empty_blocks 64, bad_blocks 0, c->nr_blocks 65



BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.2, r7676-cddd7b4c77
 -----------------------------------------------------

This is good....your router successfully flashed!
Are you still having a problem?

If so, run and paste results of the command:

cat /etc/config/network

The problem was that i cant conect to the router, or maybe i dont know how to do it, i reflashed the lede version 17. something and now i can access the router and the lua interface. Thanks for your time :slight_smile:

Did you come from 17.01 to 18.06.2 ?

There may well be something incompatible in the system config (e.g. a PCI path has changed between kernels, and switch in unaccessible with the previous config.

When upgrading to a new major version, it is best to do the config from scratch, either by sysupgrading without "save config", or by using "firstboot" command after the flash to clear all settings (if things are not running smoothly after the flash)

Your log shows

Failed to connect to the switch. Use the "list" command to see which switches are available.

which indicates that something in the switch config was likely wrong in /etc/config/network

No i came from the factory firmware, and installed the 18.06.2 and i can´t connect to the router via ip. I connected via serial like iieachii sugested and when i hit the stop i can access to the sagem flash page in 192.168.1.1 and flashed the 17 version, and now im triying to see if i can use it like a wifi repeater or someting :slight_smile: sorry but im very noob with this things, i tink that i bricked it or something

You couldn't have bricked it. As I noted, it successfully flashed. Please don't (continue to) panic.

Will you post your /etc/config/network?

You should have been able to access the router at 192.168.1.1, we'll need to see how the network is configured.

root@LEDE:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7f:b1f0:4cd7::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5'

luci is very very slow, is that normal?, maybe a older version run better in this device, its a 4mb of flash and 16mb of ram.

https://openwrt.org/supported_devices/432_warning

  • THIS IS LIKELY THE SOURCE OF YOUR ISSUES - I'm shocked v18 flashed successfully onto a 4 MB flash chip!!
  • In the future, please place code into the pre-formatted box using the </> icon.

OK, there appears to be 4 ports that should connect to 192.168.1.1. Make sure you're plugging into a LAN port. You may have to wait a few seconds for the DHCP server to respond.

I reflashed to 17 and now seems to work, but the web interface is very very slow and sometimes stop to respond. Do you recomend me an older version? or just dont use the luci interface?

Yes, 16 MB RAM is really little for 18.06.1.
And 4 MB flash is almost as troublesome as the RAM shortage.

(due to the tiny RAM amount, I am a bit surprised that even 17.01 works for you. Even that may reboot due to OOM oops, if you do anything memory intensive, like installing a large package)

Ps. Your devices wiki page ( https://openwrt.org/toh/hwdata/sagem/sagem_fast2604 contains a warning about 4/32 problems), but your device is actually even smaller 4/16, which should be non-existent nowadays. If I remember right, it was the 12.09 version (6 years ago) or 10.03 that was the last one recommended for 16 MB RAM devices...

A normal 18.06.x release image (and likely 17.01.x as well) containing LuCI will crash with an OOM on devices with 16 MB RAM, that's is pretty much the expected behaviour. The 4/32 warning really isn't a joke - and neither is running outdated/ unsupported ancient releases.

Support for 16 MB RAM devices was indeed officially discontinued with 12.09, but that was more of a realization of a pre-existing fact, rather than an active decision. These devices (and increasingly 32 MB RAM devices as well) simply aren't suitable for running OpenWrt anymore.

Devices with 4 mb flash and 16 mb memmory need to be trashed!

My guess is that there wasn't enough free RAM to start neither SSH nor LuCi. I never would have thought it would have worked with 16 MB RAM with v17 either. Most 32 MB devices only have ~5 MB free RAM. I would consider building my own v17 based firmware and remove as much as possible, including LuCi. See https://openwrt.org/docs/guide-user/additional-software/saving_space

i finaly installed the 14.03 because it is the first that "suport" my device luci are unusable, and its true that the ssh its very laggy, i was using the serial port but my usb to serial device stop reciving data. i gona try, with time to make that thing of saving space.

I want to use the router as a wifi card conected to the ethernet. Well thanks to all of you for your help :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.