I can't upgrade - why?

I have tried several times to do a firmware upgrade on my Pi 3B+. First I used the install image, which failed, of course. Then I tried the sysupgrade, both the release and the snapshot, but they won't work. I get this all the time:

I tried a couple of times to force it, but that just "bricked" (meaning I had to go back to the image backup of the SDCard that I took before starting to try this) the device. I have tried extracting the image with WinRAR. 7Zip says there is some data beyond where it should be, and extracting it on a Pi just fails. I have tried downloading with both Chrome and Firefox, nothing changes.

What file(s) are you trying to use? Where did you get them from?

176MB seems a little excessive size-wise for an OpenWRT image.

1 Like

Thanks for replying! I clicked the link for 3B+.

Which one? There's several links there.

I've just tried downloading the upgrade firmware which is just over 15mb in size. What file were you using when you took the screenshot showing you were using a 176mb file?

It is filtered by Raspberry Pi, and then i tried with the one for B+. This is the regular upgrade:

I tried the snapshot too:

The files have been the same size every time, but I think something's wrong with what I'm getting down since 7zip says there's more data then there should be.

What are you doing with 7zip? The file you download is the one you should be uploading to the device during an upgrade.

1 Like

Ah... Now it works! Thanks! Weird thing, I read this:

  1. Download the sysupgrade file. Please note that not all devices do have a firmware image called sysupgrade.bin.

So I figured the image inside the archive was what I should upload. Sorry, I'll go to my room and look ashamed for a few hours now... Thanks a lot for the help!

No wifi works after the upgrade. :frowning: And the OpenVPN setup and the 3G modem are both gone. I have set the country code on the wifi, but it doesn't seem to help. Maybe there is a breaking change between the version I had and this version. This is what I'm trying to upgrade from:

OpenWrt 21.02.2 r16495-bf0c965af0 / LuCI openwrt-21.02 branch git-22.046.85957-59c3392

Never mind, googling shows me that no non-standard packages are carried over. So I guess I need to do a reinstall of those. I just have to find out what's after-installed. Kind of annoying that Luci can't do that, but I found a script I will try, hope it works.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.