I can't get NextDNS to listen to only one interface

Hello. Follow the steps indicated by NextDNS, and on my Linux Ubuntu this configuration worked, but on the router it didn't. Can someone help me? I just want to listen to my lan and the other interfaces listen to my local DNS

what are those, specifically ?

Change listen address and forward in DHCP

list listen '10.4.4.1:53'

is .... ???

And forward in DHCP

list server '10.4.4.1#53'

I don't know why it doesn't work

you're not answering the question ...

who/what is the IP you posted ?

pretty sure the list server is a dnsmasq option.

These IP addresses are from my lan I change in the NextDNS configuration file and in the DHCP configuration file

what is the goal with this exercise ?

are you use nextdns as DNS and DHCP (not sure if it's capable of this, I don┬Ęt use it) ?

if that's the case, have you disabled dnsmasq ?

I just want NextDNS to only listen on the lan interface, not on my VLANS. That's why. I don't know why this doesn't work in OpenWrt

does the VLANs have unique subnets/IPs ?

Yes

10.10.5.1
10.10.10.1

then you probably have to use the nextdns listen option listed in https://community.ui.com/questions/NextDNS-with-keeping-Dnsmasq-on-EdgeRouter/3141381a-ea95-47c2-aa30-2715560a333b

I also follow this tutorial, however, NextDNS is unstable, it activates the settings and then deactivates. I do not understand why

the file on OS level might get overwritten by openwrt settings.

I tried using the DNSMasq file but it didn't work