I can't access the web interface of a TL-MR3420 router v1.2

Here's what happened.
I connected the router and the PC through a network cable, flashed the file "factory-to-ddwrt.bin" through the then openwrt web interface (I previously successfully flashed the corresponding image from OpenWrt Project).
Since then I can't access the user interface but can connect to the router's SSID which is named "dd-wrt".
Please help me ultimately access the web interface so that I can flash OpenWrt again.

OpenWrt is not DD-WRT

Which do you have flashed?

Edit: Unless you “forced”, OpenWrt sysupgrade for current versions generally wont flash a non-matching image. I would be surprised if it blindly flashed a DD-WRT image.

It sounds like you’re following directions for DD-WRT

I know OpenWrt is not DD-WRT.
First I flashed OpenWrt and everything was fine.
Later, I flashed DD-WRT and since then I'm having problems.
I just want to get back OpenWrt but I can't access the web interface.
Now I'm not sure if I flashed "factory-to-ddwrt.bin" or "tl-mr3420v1-webflash.bin". I downloaded both files from the DD-WRT website.

Well if there is WiFi then it looks like it's not bricked. Try to connect a LAN cable to the router LAN ports and then see what IP you get. Figure out the gateway of the router and access the web interface from there.

I would try, probably in this order:

  • DD-WRT documentation and rescources, such as their forum (I'd try wired first over wireless)
  • Trying to connect over wired as if it were your old OpenWrt install (long shot)
  • Trying to connect over wired as if fresh OpenWrt install (ssh to (even longer shot)
  • TFTP recovery -- See https://openwrt.org/toh/tp-link/tl-mr3420#flash_via_tftp

Sorry, I didn't provide enough details.
Every time I make changes to the router I do it through the wire, not wireless.
The routers default gateway is at this very moment. It was the same before but I can't access the web interface through it anyway.
Could you please give me more detailed instructions on how to do TFTP recovery on this router (TP-Link TL-MR3420 v1.2)

It seems that my only option is to flash the image through TFTP server using a serial line. What is a serial line?
My router only has ethernet ports and a usb port.

It seems that this is the only text that applies to my specific router:

Flash via tftp
Using a serial line

Download the factory update firmware: openwrt-ar71xx-generic-tl-mr3420-v1-squashfs-factory.bin
Connect your pc via serial interface.
Set up tftp server.
Name the firmware to code.bin and move to tftp folder.
Set the static IP address of the computer to: (for MR3420/MR3220 versions v1.x) or (for MR3420/MR3220 versions v2.x)
Power on the router, and type tpl if “Autoboot in ..” occurs (type fast!)
If it works you now should see something similar: ar7100>
Now you should type the following:

ar7100> erase 0x9f020000 +0x3c0000
ar7100> tftpboot 0x81000000 code.bin
ar7100> cp.b 0x81000000 0x9f020000 0x3c0000
ar7100> bootm 0x9f020000

I also don't know where to type the commands into.
And I'm not sure what to put in the Internet Protocol Verson 4 (TCP/IPv4) Properties: IP address, Subnet mask, Default gateway.
That is how you make your IP static, right?

I suppose like this?
IP address:
Subnet mask:
Default gateway:

And should I leave the DNS servers empty?

Could you please provide me with more detailed instructions. I would really appreciate it.

Since both OS use the same IP but a different web interface system, it could simply be that your PC's web browser is confused after the switch. Try clearing the browser cache.

1 Like

Thanks, that lead me to this:

So it seems that every time I want to get to the web interface I have to clear the cache and factory reset the router.
When I do that and enter, the page loads but the "buttons" (Setup, Wireless, Services, Security, Access Restrictions, NAT / QoS, Administration, Status) are unclickable. When I put the mouse cursor over them, the cursor behaves as if I am going to select the text instead of click on the button/link. I click anyway and nothing happens.
I am able to type in the fields for "Router Username", "Router Password" and "Re-enter to confirm" but when I click on "Change Password" the page fails to load and the URL turns from "" to ""

This is really not the place to debug or support dd-wrt, please head over to their forum regarding problems with that.


I'm not trying to debug nor support dd-wrt. I'm trying get back OpenWrt but can't access the web interface in order to flash OpenWrt to the router.

Whatever your end goal, your immediate questions are around DD-WRT. The expertise to resolve those are not here, but with DD-WRT.

Install OpenWrt with TFTP, assuming your router supports it.

Unless you set a password in DD-WRT, you won't be able to access the UI options. Try a different browser and then try to set up a password. Hopefully you can then flash OpenWrt.

Have you tried ?

Your comments influenced me to discover that I had set the security settings in my browser to too high. Thank you. I changed them to standard, set a new password in DD-WRT to be able to get access to UI options as @ahmar16 said, and now I can get access to the web interface but still can't flash OpenWrt to the router.

@lleachii When I tried the interface was minimalistic and that is when I found out that security settings were interfering with the functioning of the page.

When I choose a file to upgrade and click on "Upgrade" it starts and continues to "upgrade" into infinity. Well, untill I stop it. But I always wait at least 5 minutes.
I tried upgrading with:
and the stock firmware.

And it seems that some of the settings, like the firmware upgrade, just won't apply.

I tried it on both Chrome and Firefox.

P.S. I shortened the filename of the .bin files before trying to upgrade.
Here is the screenshot:

You should be flashing OEM, then OpenWrt.

All Wiki directions assume you're flashing from OEM.

Follow ddwrt instructions to flash back to TP-Link stock, then flash OpenWrt.

As long as you're running ddwrt you should look to them for support.

Realize this model is not a good candidate for OpenWrt due to small memory size.


Ok guys, thank you all for your time and help. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.