I can't access internet on my router via pppoe

hi guys

i have a modem router zte zxhn h108n v 2.5 and a adsl2 connection

i recently flashed openwrt 19.07.6 on my tp link archer c20 v5

so i set my modem/router in bridge mode and when i tried to configure pppoe wan connection via openwrt it says connection attempt failed
im really new to openwrt and it is really confusing for me as a first time user

Provided that your configuration on OpenWrt is correct, that means user/pass and VLAN, have you tried to run the pppoe from another system, like Windows, to verify that it's not an issue on the modem bridge mode?

how can i run it through windows ?
like putting modem in bridge mode and connect it to pc via ethernet cable ??

Exactly! And you need to set up a pppoe connection.

i tried it and it works just fine

Alright, now connect OpenWrt wan port to the same port you used with the Windows on the modem.
Then change the wan network protocol from dhcp client to pppoe, add the user/pass, and save.
If it still is not working, post the following:

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; logread -e pppoe

How can you run commands in openwrt

Sorry i really have no idea how to run this thing

thnx man it worked i reseted my router and tried it again it worked somehow ?

1 Like

For future reference, there is ssh to connect to the device.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.