I cannot get Dell Wyse 3040 to boot with the correct distro

HI all, not my first time using OpenWRT, i am not a coder so please understand this.
I have been able to run OpenWRT on a Dell Wyse 5070, and also an intel 5820k.

Firmware used was:
generic-ext4-combined-efi.img.gz. Version.

However when i try to run from the 3040, i select OpenWRT in the grub bootloader and then the system hangs, with no flashing from the USB device.

Any idea on what may be up?

the specs of the wyse 3040 are
Intel Cherry Trail x5 Z-8350
UEFI x64 only boot no CSM.

Some linux distros dont boot and some do boot,

Not sure if this is the issue or not, im not a coder nor able to understand whats up.

The units are for sale for 19.99 on ebay at the moment shipped.

Thank you for your work and to others who know there stuff.

Cheers

Hi all, I solved this by removing the console=tty0 console=tty80, 115200n8

This seemed to have fixed everything for me. I have left this post up that will help others out with the wyse 3040.

Cheers

If anybody kind enough know how to remove this permanently, please can they let me know. Cheers

Should be in grub.cfg?

Thank you for your reply, what's the best way of going about this, i have tried to mount the boot partition, but I got errors with mount sda1 mnt and have had no luck this way, is there any way of editing the boot partition while the USB is connected to another device?
Sorry for such basic questions.
Cheers

What error messages?

Yes, you can edit it using whatever OS capable of reading and writing the file system.

Even openwrt.

I have managed to fix it now,
I mounted from another device, and made the edits to the grub file you explained to me..
I used this tutorial to mount the drive correctly.
https://www.tutorialspoint.com/how-to-mount-usb-drive-in-a-linux-system

When i tried to mount from openwrt, one error i had of many was
"can't find valid f2fs filesystem in 2th superblock."

Its sorted now though. Thanks to your help with what to look for.

Can i kindly ask a dev to remove the the serial params from the x86 build. This will help lots of people who like myself find there openwrt wont boot. Im really not sure why the Wyse 3040 refuses to boot where as the 5070 boots fine. But once again thank you for helping me, i will leave the post up for others who search on google why the 3040 wont boot and this post will help them like it helped me.
Cheers

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.