I can not get my initial install to show NETWORK > Wireless

The Wireless setting is midding from the Network menu. Raspberry Pi 3B+. Also most unix commands are not found - lsusb, ifconfig, iwconfig, shutdown, etc. reboot does work, but no way to gracefully shut down. I get the web interface up with in the browser window, but no place under network or anyplace to setup wi-fi. And my ISP does not support ipv6, so it is disabled on my ISP's router.


Sadly, lost halfwat to first base

Packages are minimal, as most devices don’t need them and many don’t have the space. ifconfig is deprecated for Linux-based systems. ip is supplied. Other packages can be installed through the GUI or with the command line after opkg update. Most all-in-one routers don’t have software power control, so shutdown is meaningless. reboot should provide clean shutdown, after which a power cut is required for virtually all home devices.


You could use halt

Reboot works. But in the end - I still can not get wireless working and LuCI does not have the network > wireless setting. I can not figure out how to get the wi-fi working on the RPi. It does work fine with other softwares - so I need some hand holding.

According to the wiki, the built-in wireless hardware of the Raspberry Pi 3B+ is not supported yet in OpenWrt 18.06.4. Use an OpenWrt snapshot, or add a USB wireless adapter which is supported.

The web interface (LuCI) is not included in snapshot images, but can be added at runtime using opkg.


Broadcom is known for the worst driver support.

Use the snapshot or wait for OpenWrt 19.x release.

Those are either deprecated, or redundant, or should be installed manually.