I bricked my Netgear R7800 by restoring a config from an other router (different manufactor)

I successfully flashed OpenWrt https://openwrt.org/toh/netgear/r7800

Then restored the config from other router (TP-Link) and bricked it.

What do do next? How this happens?

No ping, No web ui and no ssh

Configs are device specific, as they are closely related to the hardware. Your TP-link config has probably locked the network stack pretty fully.

You might try Entering the OpenWrt failsafe mode, and then resetting the router with firstboot. (But that might be difficult due to the invalid config. Failsafe should still work, but it is not quite foolproof)

With R7800, the more sure thing to fix things, might be to enter the R7800 TFTP recovery flash mode, and then flash a new R7800 firmware image (a factory image, not sysupgrade).

(The TFTP recovery is built into the Netgear OEM bootloader, so OpenWrt firmware or settings have no impact on that)

1 Like

Although none of the network things you mention are working are you seeing activity lights like power, LAN, WAN? If so the OpenWRT may be up with a different config to what you expected. Presumably you've tried as well as whatever you were trying to configure?

Check that the WAN port hasn't become LAN due to ethN confusion. If available get PC / laptop with all networking except physical RJ45 disabled, and fire up Wireshark to see if anything is looking for somewhere to talk to.

If you have a backup of the original OpenWRT config for the Netgear then you can unzip them and compare important files. If you can then get in via failsafe or serial link see if you can restore likely looking culprits like ethN, device paths at the top of /etc/config/network, etc.

On this bit, I have pondered whether there could be a mechanism at backup / restore time to indicate lines that are "riskier" to apply and allow them to be ignored unless an extra flag is applied, rather than the whole file being accepted. I'm particularly thinking about the /etc/config/network and /etc/config/wireless files as it is the one I have to stare at most when changing the physical device but wanting to keep the same behaviour.

Since the config files tend to be section-key-value it might be possible to steer a merge type program from the command line, where something like cmerge wifi-device:type;path /tmp/wireless.base /tmp/wireless.backup would mean preserve original values for type and path entries under wifi-device sections and ignore backup ones.

I believe that it's just radio silence because all the network interface/wifi/led is just wrongly misconfigured, have you tried to do factory reset?

Otherwise... try to power on the router, wait ~10s then hold the factory reset button which will make it enter failsafe mode and you can configure it from there

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.