Huawei E3276s (stick mode) not connecting

I bought a used E3276s (Telekom Speedstick LTE III)
Updated Firmware to E3276s-861_21.400.03.00.00
Installed all cdc/ncm packages

In Openwrt it modeswitches to
P: Vendor=12d1 ProdID=1506 Rev= 1.02

and I get two ttyUSB and a huawei_cdc_ncm device, also ifconfig shows wwan0.

All as expected

But it doesn't actually connect to the internet. (blinks cyan every 3 seconds)

Stick is working with the Included "Internet Manager" and a Telekom card though, so it's not broken.
It is not sim- nor netlocked though

It also connects to other LTE networks (blinks cyan every 3 seconds) But the "Internet Manager" refuses to connect with non Telekom cards, i guess that's a SW issue though and I don't bother

I also have had the exact same stick for a long time now with the same firmware as the "new" one and that one automatically connects every time it is plugged in.

I remember when I first got it I had the same problem but then I sent some AT commands to it I found "somewhere" and at some point the stick started autoconnecting to the internet.

But I can't remember nor find those commands anymore.

Any Ideas how to configure this stick to autoconnect every time it's plugged in?

(Commands from here don't work)

BTW: shouldn't luci-proto-ncm add a new protocol to the list when I try to add an interface?

These days such modems work with OpenWrt without much effort.
Router configuration:

config interface 'LTE'                
        option proto 'ncm'            
        option device '/dev/cdc-wdm0' 
        option ifname 'wwan0'         
        option apn 'your APN here'

Modem configuration:


BTW, what is the hardware version of your stick - E3276s-what? Is it -861 as in the update file you used? That should be printed under the hood or you can inquire with AT^FHVER

1 Like

That is so strange, I already configured the interface yesterday. But luci-proto-ncm
didn't seem to work correctly (complaining unsupported interface type)

Then I gave up and rebooted.

Now I wanted to try again and send
you mentioned.

Plugged in stick, suddenly worked out of the box.

FHVER:"E3276s-150 21.400.03.00.00,CH1E3276SM Ver.C"

What does


1st google result:

AT^SETPORT="combination" - switch ports required in combination, for example, AT^SETPORT="A1,A2;10,12,16,A1,A2"

replacing A1,A2 with FF turns off need for usb_modeswitch 


Some years ago I hadn't managed to run Huawei modem with Stick firmware. So the issue is that scripts from usbmodeswitch package don't work correctly? However in ROOter (, and Gargoyle ( firmware it worked out-of-the-box. I've installed Hilink firmware, it works absolutely without any problem.

1 Like

Only problem remaining is that the stick/sim card disconnects after 24 hours and does not automatically reconnect.

not so elegant solution is to just install a cronjob and call
echo -ne '\r\nAT^RESET\r\n' > /dev/ttyUSB0

every 12 hours or so

is there a more elegant solution that's working inside the firmware of the stick?

About firmware I don't know, but you can:

  1. periodically check presence of Internet, and run your command;
  2. follow log messages using logread -f, and run your command.

No. Stick is dumb network card. Use ROOter firmware mentioned earlier and use Connection Monitoring function available there.

I have exactly the same modem and trouble as Sterlink, however the modem connects only if I first unplug and then plug it in, and the restarts the interface. Trying your suggested solution, but in what file do I type the modem commands (AT etc)?

screen, minicom, picocom, pick your poison.

or as Sterlink posted, echo, but you won't see the replies.

1 Like

Thanks, but the unit will be far away from me and everything needs to run fully automatic (like it was in the outdated Dovado Tiny AC). I found a script here. Can I replace the phrase
in the file /etc/init.d/ncm-network with

you can put anything you want in the script, but I wouldn't replace any line(s), but add new ones.

1 Like

Ok, just for the reference. I removed the scripts mentioned here and put these two lines in rc.local (before exit0):

echo -ne AT^SETPORT="FF;10,12,16" > /dev/ttyUSB0
echo -ne AT^SETPORT="FF;10,12,16" > /dev/ttyUSB1

And now it seems to work, or at least it has after three reboots.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.