HTTPS Certificate installation support

I have generated a self-signed HTTPS certificate for onion-omega2 board's login page. After providing the configurations in uhttpd config file and restarting uhttpd, I am able to get HTTPS for the IP address. But I am not able to see the login page. It shows a blank page when I enter the IP address.

I have entered the certificate in the trusted authorities for Firefox and Chrome. But it does not show the login page.

Can you please help me debug the issue.

Have you tried to clear browser cache, try private/incognito mode, try a different browser?

I have tried on Firefox and chrome browser. I have also cleared and browser cache and tried but it has not shown any result.

Currently, I have observed that I have got access to the server files but it is not able to read the index.html for the webpage GUI. This problem is not being faced while entering the IP address using HTTP.

What is the output of these commands?

uci export uhttpd; netstat -lnp | grep uhttpd ; wget -O - https://localhost

I am facing this error :

How to resolve this error?

you're not accessing OnionOS, but localhost, and that's no error at all, that's how it should be.

the workaround is in your own screen shot.

1 Like

With regards to the work around, do you mean the --no-check-certificate. When I run it with that option I get the following result:

This just the HTML for the certificate right?

I see no such thing, but I'm far from a HTML expert.

what are you trying to achieve ?

The following page should be visible after switching to HTTPS:

But so far I get:

The index.html which contains the directory for the files for the webpage GUI are located in the OnionOS directory. But on doing HTTPS, the index.html is not being read hence the GUI is not being seen. That has been my observation so far.

how does this issue relate to openwrt ?

1 Like

I assumed that I had done something wrong while configuring and installing the HTTPS certificate. That assumption has not been cleared yet. Hence, I had posted this query here.

ok, and what's our relation to OnionOS ?

I am using the Onion-Omega2 board, on which Openwrt 18.06.4 snapshot image has been loaded.

then you need to upgrade, and come back, 18.06 was EOLed a long time ago.
still don't understand where/how OnionOS comes into the picture in conjunction with Openwrt.

But for switching to HTTPS does the OS version affect the process.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like