HTTP no longer works, only HTTPS with untrusted certificate

So I usually check the software tab and do the update list and install updates manually one by one.
no problems except luci-core always seems to show a conflict error but never had a issue.

cool after updating everything I always hit the reboot button and all is well...

well last night with the latest updates it broke my openwrt for some reason because it would not let me roboot/update or even view startup tab. I figured maybe I'm missing a package searched online how to update via ssh and found this page:

did that and it worked well it let me reboot and update after and I can see startup page every thing is working, but there is a catch its no longer in HTTP mode it defaults to HTTPS and gives me warnings and its really annoying..

I open browser go to router page it goes yellow and says...

Warning: Potential Security Risk Ahead "https certificate warning"
The original certificate provided by the web server is untrusted.

I have to click accept risk and continue it will not let me use HTTP only HTTPS and says ca is bad.

I have tried fixing it from info on this page to no avail:

did everything correctly even SCP the certs and installed them on my machine still WARNINGS all day...

"The original certificate provided by the web server is untrusted."

I would just rather have HTTP back instead of this untrusted HTTPS idk what happen.
Should I just reformat and reinstall Openwrt from scratch or is there a ez fix ?

check (or/and post) uhttpd.conf

config cert 'defaults'
option days '730'
option key_type 'rsa'
option bits '2048'
option ec_curve 'P-256'
option commonname ''
option country 'US'
option state 'SomeCity'
option location 'NA'

That's one short conf file.

my fault wrong file

^ here is the right uhttpd

So is this the wrong uhttpd file again I noticed when I checked STP there was a total of 3 different uhttpd files you never said which one btw.

Anyway anyone else here seeing this care to chime in should I just wipe openwrt ??

I really don't know how to revert this I spent a few hours yesterday researching and nothing worked.

Perform backup, then factory reset, then restore backup.
That should remove/rollback user-installed/upgraded packages.

1 Like

The instruction here worked for me for Chromium but not for FF (any more?):

An answer:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.