HOWTO? Zyxel GS1900-24e extend overlay

I'm in the processo of restructuring my network to add vlans.
So i've bought a zyxel gs1900-24e that in openwrt TOH is reported as a 16mb flash 128mb ram switch.
I was very happy, the process of installation was so smooth and easy, everything was working fine until i tried to install some software, like wget-ssl to resolve the issue with ssl certificates.
the first error was: only have 572kb available on filesystem /overlay.
So with a df -h command i've discovered that overlay has only 896k of total space.
i have installed the initramfs image from the gui, then scped the squashfs image and done a sysupgrade following the guide.
so, how can i extend the space in overlay?
Thanks in advace for every help

you can't, AFAIK there's no way to attach storage to your device, no SATA, no USB, no mPCI/mPCIe, or any other port.

16 MB flash, but dual-firmware (even if OpenWrt can't use the second partition right now), leaving you with 6976 KB maximum firmware size. It's normal/ to be expected, extroot is not possible - but at the same time, it's a switch, no need to install many packages. This is the only known drawback of the ZyXEL gs1900 series.

1 Like

Well, first of all, thanks for the quick reply @frollic and @slh.
I know i have no usb/sata, but what says slh make sense to me, and i would be very happy to live with an 8/128 device, like i already do with some other openwrt wifi devices!
What sounds weird to me is this:

root@shakfw:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.0M      3.0M         0 100% /rom
tmpfs                    59.7M      1.0M     58.7M   2% /tmp
/dev/mtdblock8          896.0K    340.0K    556.0K  38% /overlay
overlayfs:/overlay      896.0K    340.0K    556.0K  38% /
tmpfs                   512.0K         0    512.0K   0% /dev

in overlay i have only 896k... in ram half the size reported...
So the question is: did i do the installation process correctly?
seems the 6976k space size is far away from what is reported.
Can i make something to arrive to that size?
Thanks in advance

/tmp is 50% of your total RAM, this is normal.

do a cat /proc/mtd

here it is

sorry, don't consider the first message, i did catted the mtd of the wrong device (a tp-link as you can see).
This is the correct one!

root@shakfw:~# cat /proc/mtd 
dev:    size   erasesize  name
mtd0: 00040000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 00010000 00010000 "u-boot-env2"
mtd3: 00100000 00010000 "jffs"
mtd4: 00100000 00010000 "jffs2"
mtd5: 006d0000 00010000 "firmware"
mtd6: 00310000 00010000 "kernel"
mtd7: 003c0000 00010000 "rootfs"
mtd8: 000e0000 00010000 "rootfs_data"
mtd9: 006d0000 00010000 "runtime2"


  7143424 byte total
- 3186756 byte kernel
- 2970282 byte squashfs
   986386 byte

- padding/ alignment to erase block borders (64 KB)
- filesystem overhead for the overlay (jffs2)
1 Like

Well, thanks for the clear explanation and thanks for your works guys!

I had a lot of plans for this switch... but now.. new plan! :smile:
I'll offload all the services to a new server! :smiley:

if you don't use ipv6, you could try to remove the odhcpd6c, and add the wget-ssl, by making a custom image at
firewall4 could perhaps be deleted too, unless it's needed for VLANs ...

The easiest approach would be getting rid of wolfssl (there is no wireless on these switches anyways) and installing mbedtls for luci/ wget instead, should free up ~300-400 KB (via imagebuilder).

1 Like

yeah, i'll install all dns/dhcp/adblock etc. services to another server, and i'll study carefully what packages i need on this switch.
the wget-ssl i was trying to install was to download the packages via ssl.
I've solved removing the https to http.
this has to be the main L2-vlan switch, so yes, i will remove dhcp, dns and everything else except vlan and fw.
it will be in the dmz of the main dsl router.
Thank you again for your support!

You're severely underestimating how weak the MIPS SoC in these switches is. The hardware is designed for switching, nothing else pretty much.

this switch is sold as a managed switch from zyxel, and i will use in that way with openwrt, so i do not understand, what's the matter in using it in this way?

I was referring to your plan to use it as a router and burden it further with an adblocker etc. Like I said, the hardware is designed for switching and its routing capabilities are minimal. Both on OpenWrt and OEM.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.