HOW to use WPS on Linksys WRT

As usually, I enable to WPS working as this:

opkg update

# if you remove it, it will not work
# v22
#opkg remove wpad-basic-wolfssl
# v23
opkg remove wpad-basic-mbedtls

# it will start working after re-install
# v22
#opkg install wpad-wolfssl hostapd-utils
# v23
opkg install wpad-mbedtls hostapd-utils

reboot && exit

# wait about 2 minutes
hostapd_cli -i wlan1 wps_pbc

hostapd_cli -i wlan1 wps_pin any $PIN

it always after wps_pbc I get OK

now I get like this:

Failed to connect to hostapd - wpa_ctrl_open: No such file or directory

what the problem could be?

with v22 it works perfectly. with v23 as it says the text up

the doc is now fixed as well.

They said I should enable this ctrl_interface_group=0 as follows:

Do I have to install hostapd in additional to the utils?

ok, i found in v23:

hostapd_cli -i phy1-ap0 wps_pbc
hostapd_cli -i phy1-ap0 wps_pin any 1234

you can also use in the main screen in luci in the radio1 start wps button

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.