How to use PPPoE and lan-wan bridge on the same port?

Hi there.

I use Turris Omnia connected to ISP with PPPoE. The same wire is used to deliver IPTV to the STB. Previously it worked on TP-Link WR1043ND with the default firmware, where you just pick up the desired port for IPTV, and thats it. Now, if I start lan0 bridge to wan, STB on lan0 starts showing IPTV, while PPPoE loses connection.

Please, help me with that issue.

Have tried lan4 with no luck. ISP support can't help me. They just gave me some information, which I have no idea how to use:

  • They have VLAN 2014 both for Internet and IPTV on my port
  • My STB uses unicast for IPTV

That would be done by hardware switching. Is the router running swconfig or DSA? Assuming you are running official OpenWrt, not the Turris version, in swconfig you will have a Network-->Switch page.

The router running DSA and Turris version of OpenWrt, so there is no Network → Switch page. I thought that Turris contribution to OpenWrt consisted mainly in adding its logo :slight_smile: Is it a deal stopper here and should I ask my questions to Turris or install official OpenWrt to have IPTV and PPPoE working simultaneously?

You need to ask Turris since you're running their software.

If it is regular DSA, the configuration would go something like this:

  • Connect to the router by wifi so you don't lose contact while reconfiguring the Ethernet.
  • Move the wan port into the same bridge with all the lan ports. All ports on the same hardware switch should be in the same bridge.
  • Set up bridge-vlans to differentiate the lan and wan functions. The wan vlan number must be 2014 to match what the ISP hardware requires. The lan number can be any other number 1-4094, usually 1 is used.
  • In the lan bridge-vlan, turn on the ports that will be connected to ordinary LAN devices like desktop computers to untagged. These are off in the wan bridge-vlan.
  • In the wan bridge-vlan, make the port that goes to the modem and the one that goes to the TV box tagged. These are off in the lan vlan.
  • Attach the lan interface device as br-lan.1 and the wan to br-lan.2014. Do not refer to the ports directly in any interface configurations.

Great thanks for the tutorial. I'll back to you with the solution.