How to upgrade from stock OpenWrt to 'real' OpenWrt for GL-iNet (GL-AR750 and GL-MT300N-V2)

I purchased these router to use exclusively with Openwrt. The stock, modified, openwrt image works fine (19.05). I would like to upgrade to the latest "real" OpenWRT. I have tried several times without out success.

I am following the wiki guide here:

I can easily flash am image either using the vendor UI or LUCI however the end result never works and I am getting confused.

First, if I am starting from the stock image, do I use the install image or the upgrade image? The device already has an older modified version of openwrt on it so I am not sure if this is considered an upgrade or if I need the full install because it is not a "real" openwrt.

I have tried both and they flash successfully but the radios are never configured properly.

Scenario 1:
If I select to save the settings, luci re-configures and renames the interfaces on first login and breaks the ethernet port conflagration so I can't connect cables to the ports. I don't see anything about this in the notes.

Scenario 2:
If I flash the image and do not choose to save the settings, I get what looks like a default openwrt image with only 1 default radio (this device has 2 radios). Is this right? Shouldn't the image at minimum know the device has two radios or am I expected to have to create all the devices, link them to interfaces and set up all this configuration manually?

For example, when I install Linux on a laptop, I don't have to create a device for the wireless card (wlp3so), the kernel detects the device, names it and links it to an interface, etc. Does openwrt work the same way or do I need to setup all this low level device stuff myself?

I have tried all this on a second device GL-MT300N-V2 with the same results. The stock modified openwrt works fine but I can never successfully upgrade to the real version. I always end up with a result where the radios, interfaces and devices are missing or misconfigured.

Is this the normal experience or am I doing something wrong?

I bought the AR750 device recently, flashed it using the normal webgui and sysupgrade image.

Both radios were there, disabled, but that's normal.

Might have upgraded to 19.08 instead of 21.02, though.

The important aspect would be not to retain the configuration of the other firmware, as incompatibilities are likely.


For the GL-MT300N-V2 there is only 2.4 GHz

Thank you. I will try 19.08 instead of 21.02. When I use the webgui and sysupgrade image I end up with a /etc/config/wireless file that has only one radio (radio0) which is 2.4g. Can you confirm you see both radios? I tried it several times yesterday and always ended up with this result. I will try it again today to 19.08

The reason why I elected to try to retain the settings is because at least it has all the radios, although as @slh mentioned this also results in a incompatible configuration.

Thank you yes I do realize that. The problem I am having is with the other device, when I try to upgrade it, I end up with a image with just radio0 (2.4). I will try it again with upgrading only to 19.08

Yes this is what I thought too, especially because the naming scheme of some of these devices looks different. I wanted to upgrade a clean image however when I do that I end up with a /etc/config/wireless that just has the two default entries. It doesn't have my devices and interfaces. Is this normal for an openwrt firmware or should the firmware at least have two radio devices if the router has two radios?

I am new at this so I don't know what is the expected result here. I tried flashing 10x yesterday and never ended up with a good result. I got closer when I tried to save the config but this isn't ideal either, for the reasons you mentioned.

This is the image I used that ended up with only one radio:

Can you confirm you had success with the 19.08 version of this firmware?

I do not see a 19.08 here: it goes from 19.07 to 21. Did you mean 19.07.8?

Also, critically, when you upgraded did you check the box to keep the settings or not?

With the AR750 if that is with the new 21.02 firmware

ssh -> Ip root + password

cd /etc/config/
rm *
firstboot -> yes

Run iw list to see if two phy's are reported. That information is used by firstboot scripts to build out the default /etc/config/wireless. If you don't see two radios in iw list, check the boot log for problems with the ath10k driver.

Thank you for this comment. It worked, I now have two devices running the latest version of the 'real' openwrt. This is important because I would like to run these as mesh points and so I wanted the same os version and networking config.

Thank you, I followed this advice along with using the sysupgrade path and it worked.

Thanks for this comment, it is very useful for understanding how openwrt works. Do these scripts run when upgrading using the " Firmware OpenWrt Install", the *.intramfs.kernel.bin version or just the *.sysupgrade.bin version?

I have one device left to upgrade. It is a GL-B1300 running a much older, modified openwrt version 15.05.1. I noticed that the device notation and setup from this version is quite different than the newer versions so I do not want to use the "retain settings" option when flashing the image. Do you know, will these scripts run successfully if I run the sysupgrade.bin version on this device.

I am hoping the end result will be all three devices with similar network and wireless configs using the same interface and device notation etc. which will make it much easier to administer.

Thank you. I have everything up and running now. Thanks to everyone for your assistance.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.