How to unstuck “software OpenWRT-OS-V1.0” to upgrade WE826-T2 for Sierra EM7455?

Hello,

Thank you for that amazing forum where I’m learning how to create my LTE 4G connexion with OpenWRT systems.

I bought a WE826-T2 under the “Open WRT label” and I receive a WE826-T2 router with the “software OpenWRT-OS-V1.0”. Below the link to the product presentation :

On the page web interface 192.168.1.1 I have just the password “admin” which is requested without login option. Unless if I mistaken on a classical OpenWRT interface we precise
login : root
pssword : admin.

Before to order the product I checked if that was possible to integrate a Sierra EM7455 and great the hardware allow that. Unfortunately the “software OpenWRT-OS-V1.0” doesn’t recognized the Sierra EM7455.

The second step consisted to check if the WE826-T2 can be upgrade for this particular Sierra 4G LTE card, and indeed the product presentation on that site confirm that everything should be fine :
"The Sierra Wireless EM7455 and EM7565 are M.2 modems and require a Mini PCI-E to M.2 adapter to be used in the WE826-T2.".

Finally I confirmed the possibility to upgrade the router with OpenWRT :
https://openwrt.org/toh/zbt/we-826
Unless if I mistaken the Sierra EM7455 is supported.

But the Chinese “software OpenWRT-OS-V1.0” refused after download to upgrade the WE826-T2 with :
openwrt-18.06.2-ramips-mt7620-zbt-we826-16M-squashfs-sysupgrade.bin
or
openwrt-18.06.2-ramips-mt7620-zbt-we826-32M-squashfs-sysupgrade.bin

Below the link to the process that I followed :

Questions :
Is it necessary to flash with an interface USB to M.2 adapter, and if yes how can I do that ?
Maybe I can find hide pages 192.168.1.1 for the root access ?
Is it an another way if the soft seems stucked ?

I really wish that the seller will sent me the unlock .bin file, but I have strong doubts. Is it allow to sell product under the OpenWRT label with stuck Freeware ?

But maybe it's super easy and I'm just paranoiac ?

Do you know a way to reduce the losses please ?

Thank you for your time.

Nicolas
Below the screenshot of the first page without login options similar on the HLWR822. The password is admin without Root Privileges necessaries to flash the router I guess.

You are mistaken.
OpenWrt default password for root is empty.

Sounds like you have somebody's private OpenWrt derivative variant with modified default settings, package selections etc. Likely the seller has modified the code to to work with his hardware selections and has also modified the config heavily.

You should try to login to the SSH console, instead of the GUI.

Alternatively, you should be able to use the OpenWrt failsafe mode (at boot time) unless the seller has disabled it. In failsafe you will bypass the password enquiry and will have root access. See wiki about info on failsafe.

The seller should send you the modified sources If you ask, but that may be hard to enforce.

Hello,

Thank you for answers.

I guess the failsafe mode is an equivalent at the Firmware Recovery Mode ?
https://ltehacks.com/viewtopic.php?f=12&t=5

New tests today to unstuck WE826-T2 and HL-WR822 MT7620N routers.

Have a nice day

Not quite. At least the advice seems a bit strange.

Normal Openwrt failsafe is decsribed as OpenWrt wiki (instead of some third-party specific advice site):
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

Entering failsafe mode

Make sure you use a wired connection, since the failsafe will disable your wireless connectivity.

On most routers, OpenWrt will blink a LED (usually “Power”, may be other) during the boot process after it gets control from the initial bootloader (like u-boot). OpenWrt will rather early in the boot cycle check if the user wants to enter the failsafe mode instead of a normal boot. It listens for a button press inside a specific two second window, which is indicated with LEDs and by transmitting an UDP package.

To enter failsafe mode, follow one of the procedures listed below:

Recommended for most users: Wait for a flashing LED and press a button. This is usually the easiest method once you figure out the correct moment.

But if your device manufacturer has tried to lock down the device by changing root options etc., he may also have removed the failsafe possibility.

1 Like

Unrelated to the lock-down situation:
It may be hard to add drivers for hardware components, unless you find the required drivers in the official download repo of the exact build that you using, or you compile the whole firmware (including the driver) from sources by yourself. There is a rather strict kernel module checksum verification using kernel versions and all build options, which tries to prevent installing incompatible modules. So, it may be rather hard to change hardware modules or update drivers, unless you get all modules from the same download place, or all needed sources from the same place.

################################################
Method to upload the good .bin file in the WE-826 on Linux Ubuntu with a RJ45 wire

FIRST STEP
Ethernet RJ45 specifications ipv4 in "edit connections"
IPV6 -> ignore

IPV4 :
IP: 192.168.1.5
Mask: 255.255.255.0
Gateway : 192.168.1.1

Connection mode : Manual

=============================================
SECOND STEP :

  • Log the 192.68.1.1 router "welcome page"
  • switch off the router or unpluged it
  • Switch on the power and keep push the reset button at the bottom
  • Check when the wifi and LAN leds are ligthtening, stop to push the reset button and refresh the 192.68.1.1 page
  • Now normally you have a simple web interface to upload the new .bin file without restrictions
  • wait the automatic reboot

Below the link for the flash generated with the .bin file for the system "the rooter project" dedicated to the ZBT-WE826(16M):
https://www.ofmodemsandmen.com/download/GoldenOrb/we826-GO2019-03-10.zip

Maybe for install the Sierra EM7455, I have to use :
https://openwrt.org/toh/zbt/we-826
downloads.openwrt.org/releases/18.06.2/targets/ramips/mt7620/openwrt-18.06.2-ramips-mt7620-zbt-we826-16M-squashfs-sysupgrade.bin

Thank you for your help to solve the first part of the glitch.

The second step of this post consists now to upgrade the ZBT-WE-826(16M) with the Sierra EM7455.

Glad you got it running!

A new thread on the modem would help others in the future.

The modem is USB connected so a M.2 to miniPCIe adapter should work, assuming it physically fits. An external USB case is also an option. Make sure you get the proper “key” in either case, as there are a couple different M.2 configurations.

hi

i have a we826-t2, i am trying to flash this firmware, i can see the thw web interface to upload the .bin file, i can submit the file but at 16% the upload was failed, what do you think that is wrong??

so i bought a router on ebay similar situation thinking i would be able to put my at&t sim card in and it would work.. that was not the case.

i bought this item

it comes with a Unicom LM9106 modem.

I made the mistake of loading a different version of Openwrt and now the modem wont show up. anyways i decided to purchase a Sierra Wireless MC7455 CAT6 4G LTE-A Modem from ltefix.com to install in the we826-t2 so the firmware i loaded will recognize the modem. unless someone else knows how to get the Chinese modem i have to work lol.

I'm really new to the router/modem stuff . anyways did anyone figure out how to get around the factory loaded Chinese software and use the modem that is pre installed?

Hello daftdrifting,

You have a we826-t2 which is recognizing MC7455 CAT6 4G LTE-A Modem with openWRT ?

"sfx2000" precised on an other post that it’s necessary to install with ssh “usb-utils
& minicom” upgrades for openWRT version. I guess it’s also necessary to install “libqmi-utils ”, but this is a ubuntu linux name.

If you want to do an easiest configuration, you can install the goldenorb version to test the material, and after install openWRT which seems a light cleanest version :
https://www.ofmodemsandmen.com/firmware.html
ZBT WE826/WE1026/WE3926 -> Download

After you’ve to precise general specifications, example :

Maybe it's also necessary to precise in the Firewall option "unable" TTL : 65; but I'm not sure.

Thank you to the Godenorb team because my modem with the Sierra 7700 is working now in 3G for the moment. The LTE isn’t detected , but I’m not using big “reception antennas”.

Finally, my problem was a SIM card stuck, because I took another SIM card with a new number, and exactly the same internet offer, and it’s working on an other “emission antenna”

Good luck daftdrifting

I haven’t installed the new modem yet. Waiting for it in the mail. My router came from China with a modem that no firmware but the stock locked firmware can recognize . So I’m at a loss till I install a known Sierra brand.

Hello, I want to ask You, Have You tried to put to openWRT the modem Sierra EM7455 with this N-NGMA adapter? link:

https://drive.google.com/file/d/1N9AXDaPg2MqK00L9FqDh753sOkltuZOh/view

is it worked or You? I just bought a brand new Sierra EM7455 (dell brand, will do debranding after receive it), also ordered adapter from aliexpress (N-NGMA, the same as per yout Your picture), and gonna upgrade my GL-MIFI with Golden Orbs (ROOTer openwrt OS, the GL-INET very slow on this router, decided to use Golden Orbs for a time I liked it very much), also I checked that ROOTer is suppoerted with Sierra EM7455 modem. But the main question is, the adapter is working or I need to look for other adapter? I will wait for Your answer guys. Thank You.

Can I up the topic? Can Anyone can help me?

What exactly is the question ?

PDF shows failed upgrade/install of openWRT, while you write about the Sierra EM7455, and the passive adapter.


The question is:
Can I use this model "N-NGMA" M.2 to mini PCI-E adapter (please see picture by the link):
https://drive.google.com/file/d/1N9AXDaPg2MqK00L9FqDh753sOkltuZOh/view

with Sierra EM7455 modem, all together will put in to my GL-MIFI router with OpenWRT GoldenOrb firmware (this Sierra EM7455 modem supports GoldenOrb firmware I checked on the website) in GL-MIFI router's mini PCI-E slot? Is it will work for me?

I'd say no, the N-NGMA appears to be an mSATA SSD adapter.

The interface for the Sierra is USB - https://www.sierrawireless.com/products-and-solutions/embedded-solutions/products/em7455/

You probably need something like this https://www.ebay.de/itm/191750444584 , physically same, electrically different.

Thank You for the information.
Ok I will buy it. With this adapter will work 100% correct?
At the moment my GL-MIFI router has 3g modem Quectel UC20-e, it's very slow during these days. I know that this router is not the best selection in these days, but I bought it for 27 EURO (used), and want to upgrade, but Quectel modems with PCI-E connection are very expensive, about 35-40 EUR. I bought Dell branded Sierra EM7455 for 15EURO (brand new), will do debranding with linux to make Sierra EM7455 with generic firmware, and gonna use with this adapter. Also will need to buy mini PCI-E to USB adapter for it, but it will be cheaper as buy new Quectell or other brand modem, also will have option in a future to use with other hardware, as Sierra EM7455 are giving download speed 300mpbs, and upload 50mbps speed. Also will upgrade GL-MIFI internal GSM antenna instead of 2dbi to 5-8dbi antenna. All the process will put there, for other people, after receive all the parts, as I am buying it from ebay or aliexpress. Also thank You for supporting, I hope all your and my information will help other people too. Have a good day!

Other question is: why that men was using M.2 sata to mini pci-e adapter for it's Sierra EM7455 modem? Is it combination was worked for him?

No I'm not 100% sure, I'd go for USB instead, to be safe :stuck_out_tongue:

If the adapter have all leads connected it'll probably work

This looks better https://www.ebay.com/itm/EM7455-to-MC7455-adapter-Convert-EM7565-to-MC-mPCIE-LTE-to-M-2-1-only/154072740791
Gives you the format change, and a SIM card slot.

Thank You that You are helping me.
The problem that I don't want USB, as in my case it's not stable ( I have NEXX WT3020 with Padavan firmware installed, to it is connected Huawei E3372h-153 in Stick mode, but it has some issues, I cannot find the solution already year, also I stopped to searching of it. On this router NEXX are made Openvpn client, setup rules, that if vpn client down restart the vpn client, also periodically restart router few time in a day, to lan connected other lan client. The openvpn client and router are working stable, but issue is that lan client cannot register to some server through openvpn client, and i must manually reconnect the Huawei stick (in padavan firmware is button recoonect internet), after1-4 reconnects the lan client registering to the server. I have found information if I want really stable internet connection, need to choose router with internal modem, like GL-MIFI. Thats why i made this selection. I need to have super stable connection, as it will be OpenVPN client, which I physically do not have possibilities to reconnect it and so on. I think with solution with GL-MIFI + GoldenOrb+new modem with adapter + openvpn I will have it. After all the projects, will write how it works (stable, not stable).