How to unbrick this case! My router TL-WR841N

Hello, I wanted to know if it is possible to recover my router. I needed to return the router to the original firmware and try to load ( i download this ) it from the local page (

Being a novice user, I left it there "working", but after 1hr I find it with a strange LED pattern.

I also tried making a TFTP server which in theory worked, according to the LOG view, the file was copied but after that it returned to the same LED pattern.

So I would like to know if someone could give me some advice, or tip if I am making a mistake in any step.

Thank you very much in advance, and excuse my English.

Have you seen these instructions?

1 Like

Glad to see your answer, I have 2 queries.
First of all, no, I had not seen that instructable. As far as I can read, it belongs to the model that includes a D at the end "TL-WR841ND", I really don't know what the difference is between it and the one with the D.

Second, assuming they apply equally, I did the step of downloading the OEM version provided by TPLINK and the name contains 'boot'.
From what I understand I have to cut something but I can't fully understand, the commands suggested by 'DD' I think they are from linux? Or are they commands that can be entered into the router? I'm a bit lost in that regard.

I really appreciate you taking the time to respond and I would appreciate it even more if you could continue supporting me with this topic! All the best.

Since it is bricked now, you will need to TFTP recover, which is also described on the model page.

The recovery process uses an un-modified copy of the factory firmware.

Hello! I understand what you're saying, in the first post I mentioned that I already tried doing it with a TFTP server. Now I tried again to take a screenshot and be able to attach what the log returns.


As you can see, it makes the connection perfectly, the router requests the file and it is sent correctly. But the router later works for a few seconds and returns to the "bricked" state.

In the image you can see that I downloaded the v13 file, and that it contains the word boot, so I don't know if I should cut something, since I don't quite understand the first thing that d687r02j8g attached.

The only thing I did to the downloaded file was change the name, but since it doesn't work I think it's not enough.

I leave a link of the LED pattern, in the "working" state and then back to the "bricked" state.

Thank you for your response, I'll be attentive in case you could continue supporting me with this problem.

That looks right. Your router should be marked v13(ES) on the label. The country code doesn't matter with OpenWrt, but the stock firmware must match it.

The next step would be to use serial.

1 Like