How to setup wireless bridge?

Hi all,

I have a ASUS router with OpenWrt 19.07.x.
I want to setup a bridge between eth0 and wlan0.
I expect wlan0 is STA and bridge with eth0 together, wlan0 will connect to my home router, eth0 will connect to my camera. Camera will get ip from my home router. Following is my setting.

root@aa-945a:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'dhcp'
        option ifname 'wlan0 eth0 usb0'

root@aa-945a:~# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/ocp/18700000.sdhc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'sta'
        option ssid 'EricWrt'
        option encryption 'psk2'
        option key 'qwer1234'
        option macaddr '02:01:38:07:94:5a'

From logread

Thu Oct 19 09:19:38 2023 daemon.notice netifd: radio0 (2186): command failed: No such device (-19)
Thu Oct 19 09:19:38 2023 user.notice mac80211: Failed command: iw phy phy0 interface add wlan0 type managed
Thu Oct 19 09:19:38 2023 daemon.notice netifd: radio0 (2186): Interface 0 setup failed: BRIDGE_NOT_ALLOWED

bridge

root@xodc3916-945a:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.00013807945a       no              eth0
                                                        usb0

If any project I can refer or suggestions will be great, please help. Thank.

First, you should upgrade to the latest OpenWrt, assuming your device is still supported. 19.07 is EOL and unsupported. It contains many unpatched vulnerabilities.

You'll want to reset your device to defaults, and then use relayd to achieve this goal:

1 Like

Hi @psherman

Thanks, this works to me.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.