How to setup OpenWrt on Archer C7 + Vodafone Router

I have a Tp-Link Archer C7 that I bought to use as a router with my previous cable provider (Virgin Media UK); Virgin'r router was a disaster but luckily it was possible to set it to modem only mode.

Now I have a DSL modem from Vodafone (connected to the phone plug), which I would also like to use as just a modem and use my Archer C7 (flashed with OpenWRT) as the router. I know, having a router with a dsl port would have been easier (although I'm not sure Vodafone would allow me to use my own router)

I have the Vodafone router setup with the address and DHCP on and broadcasting its own wifi, let's call it "WiFi1"
The OpenWRT router is connected (via WAN) to one of the LAN ports of the Vodafone router and set up with and DHCP also on and broadcasting "WiFi2"

This way I can now disable Wifi1 and just use WiFi2, but I've got a feeling this is not completely optimal.

Vodafone router does not support 'bridge modem' mode. (I presume you previously used Virgin Hub in 'modem' mode. Otherwise known as 'bridged' mode)

So your only options are to configure the secondary router as you have done, which is not recommended due to 'double NAT' firewall issues. This is only likely to be a problem if you operate any servers and need to set up port forwarding rules. Some games consoles may have issue.

Alternatively, configure the secondary router as a dumb wireless access point and let the Vodafone router handle all router functions.

If you have FTTC Superfast fibre broadband, you can still get hold of Openreach VDSL2 bridge modems on eBay. Huawei HG612 (type 3B), but many are up to 9 years old and coming to end of life and they stopped making them in 2014/5. There is also a 'less desirable' Openreach modem made by ECI (B-FOCuS V-2FUb/r rev.B) which was discontinued in 2016. TPlink TD-W9970 wifi router also offers bridge mode. If you opt for using a bridge modem, you will have to contact Vodafone customer services to obtain your unique username and password to enter into PPPoE login details of your openwrt router.

The problem I'm trying to solve are two:

  • when I watch Netflix on an Apple TV 4th gen I often see some low resolution scenes (but no buffering); apparently this is due to my connection/wifi
  • sometimes during work conference calls with Microsoft Teams I get disconnected

Would using the TP-Link OpenWRT router as a simple access point and still use the Vodafone router as a router solve my problems?

I doubt changing it to dumb access point mode will solve the Apple TV issue.

If you witness disconnections with MS team while connected to Vodafone router wifi SSID probably won't make any difference imho.

You mentioned you previously had Virgin cable. Did you have these issues with I presume same TPlink router with same OpenWrt configuration?

You also need to establish if your 'disconnections' are due to broadband connection dropping, or a new issue with wireless not seen before with TPlink. eg. are 'wired' devices affected?

If it worked fine with Virgin, apart from replacing the Virgin Hub with the Vodafone router and turning its wifi off, have you changed anything else, such as location of routers etc?

I don't know much about the VOX3/THG3000G router, but I understand it is an improvement over the original first generation fibre router which Vodafone used to ship.

I'll need to find a lan cable long enough to try and connect the AppleTV directly to the router

In the Vodafone router there is this option

Shouldn't this expose my TP-Link router to the internet? That IP is the ip of the Tp-Link router on the vodafone router network.
I'm now trying to access my raspberry from the internet...

If you don't wish to drill holes through walls or invest in mesh wifi solutions, perhaps try a pair of powerline adapters for your Apple TV box. About £25 from Amazon/Argos for TPlink models. Powerline solution is 'convenient compromise', not necessarily best for speed, latency or reliability based on my experience.

Regarding effectiveness of DMZ mode on the Vodafone router, someone else may be able to respond. Otherwise, may be best directing question to Vodafone forum. DMZ is not a 100% substitute for pure 'bridge' mode imho.

So I’m now using the TP-Link router as my main router (Vodafone router connected to WAN); Netflix seems to work fine now
However my IoT devices controlled via MQTT (Shelly) seems to have become a lot slower; switching lights on and off via Home Assistant was instantaneous, now I may have several second of delay

fwiw, if everything previously worked with TPlink with Virgin hub in modem mode, only suggestion is read my original first reply and perhaps try a VDSL bridge modem to see if it will resolve your issues? A used openreach or TD-W9970 cost from around ten quid off ebay? (I'm assuming you have FTTC VDSL2 superfast broadband)