How to setup a subnet in a router (with 2 radios) from a mobile hotspot

GL-B1300 has two radios: Qualcomm Atheros IPQ4019 802.11bgn (radio0) and 802.11acn (radio1). The stock firmware allows me to connect to my LTE mobile hotspot and create a subnet with the both radio interfaces (2.4 and 5 GHz) and also configure Wireguard VPN. However, after I install OpenWrt the Wifi configuration is not so simple as I thought.
In general, I would like to have such a topology:

I tried the configuration from this documentation https://openwrt.org/docs/guide-user/network/wifi/relay_configuration using relayd. However, my Linux networking knowledge is not expert enough to understand the configuration.
My result after following the documentation:

  • I can create a new subnet 192.168.1.xx with a new wireless SSID, and an internet connection from my LTE hotspot. However, I can't access the OpenWrt webUI through 192.168.1.1 via wifi and the IP of my laptop has 192.168.144.xx instead of 192.168.1.xx.
  • In order to access the WebUI, I need to connect the GL-B1300 router to my laptop with an ethernet cable, and set a static IP of my ethernet manually, for instance to 192.168.1.5.
  • Moreover, the OpenWrt documentation recommends to set a static IP for the wwan interface https://openwrt.org/docs/guide-user/network/wifi/relay_configuration#configure_static_ip_address_on_wwan_interface. However, my Android mobile hotspot doesn't allow me to set any static IP.

My questions:

  1. Did I read the correct documentation? If yes, what could be wrong that my laptop still has the IP of the hotspot's subnet?
  2. What is the name or the suitable term of the above topology? Is it "relay bridge" or "routed client"? So that I can read the correct documentation.

Thanks in advance.

I've just solved the issue with this steps after a system reset:

  1. Let the "lan" wifi interface as default (192.168.1.1) or change it to another subnet.
  2. Start a wifi scan from the 802.11acn radio1 and connect to my LTE hotspot like described in this documentation https://openwrt.org/docs/guide-user/network/wifi/connect_client_wifi.
  3. Activate the default Openwrt SSID as "Access Point" mode from the radio0 and activate the wifi encryption.

However, if I add a new wireless SSID "OpenWrt-5G" as the "Access Point" mode from the 802.11acn radio1 (5Ghz), my laptop can't find the SSID. Does anyone know why?

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'sae-mixed'
	option key 'xxx'
	option ssid 'OpenWrt'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'sta'
	option network 'wwan'
	option ssid 'LTE-Hotspot'
	option encryption 'sae'
	option key 'xxx'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt-5G'
	option encryption 'sae-mixed'
	option key 'xxx'
	option network 'lan'