How to set up on WAP (EAP 225)? How to get to one device thru another?


  • Have Router1 working with OpenWRT.
  • Now installed OpenWRT on EAP225 WAP.
  • Can ssh to EAP225 if I connect directly with Ethernet.
  • But then there is no internet available because only 1x port.
  • How do I ssh to EAP225 through the router?
  • How do I get the internet to EAP225 so as to be able to download packages and such?
  • Then, how to set them up in relation to each other?

PS I am not very sophisticated so please feel free to include basic stuff.


(FYI I had a few other links to specific pages and such but this forum limits new users to 8 links per post so had to remove some, but I left the [enclosing square brackets] so you will see.)

I am installing over factory firmware on [TP-Link EAP 225v3] wireless access point [(openwrt-ath79-generic-tplink_eap225-v3-squashfs-factory.bin)]. The install instruction on the [git commit] is:

Flashing instructions:

  • ssh into target device and run cliclientd stopcs
  • Upgrade with factory image via web interface

I couldn't figure that one out until via scattershot websearch found docs for TP-Link EAP235-Wall v1 (related but not identical device) which includes slightly more explicit instructions:

Enable SSH in the web interface, and SSH into the target device.
Run cliclientd stopcs, this should return “success”.
Upload the factory image via the web interface.
Once the firmware update is done, the device will reboot and OpenWrt will listen on

I have the EAP225 connected to LAN port of existing router (also OpenWRT) which has assigned it as per its configuration. I wasn't able to find a web interface for that, or ssh to it.

When I connected my computer directly to the Ethernet port on the EAP225, I was able to ssh to Couldn't find a way to bring up web interface. (Maybe this is expected as mentioned in [Log into your router running OpenWrt] .) Also I notice that /www is empty. So, obvious questions:

  • Is a web interface available here and if so how to access?
  • If no web interface, is it possible?
  • If not possible, where can be found info about set up of router via cli?

Found instructions about how to install LuCI, but of course without internet access it's not possible to obtain the packages. (As this device has only 1x Ethernet port.)

I am new to all this stuff so I am also not sure if there is a way to go computer --> router1 --> EAP225 via ssh (and also to get the web interface if and when it is available)? There must be. I tried sshing to router1 and from there sshing to which I thought was probably going to work, but

ssh: Connection to root@ exited: Connect failed: Host is unreachable

I have heard of port forwarding and thought maybe that would be the solution but I am confused by the available documentation.

I have been roaming around the documentation and found some potential paths forward, below. But before any of this I need to be able to get to the EAP and the internet at the same time.

I'm usually good to just try things til a working solution is found. But in this case, I don't want to screw anything up too badly because apparently if you brick the device the only way to recover is by soldering. And I don't know if this is the best way to learn to solder.

Any assistance appreciated. :slight_smile: should be OK, but it also depends on the intended use case.

Looks weird.

router1 --> EAP225--> (wirelessly) computer 
router1 ---> EAP225
        |--> computer

Openwrt have a static IP of per default, it'll not change no matter how you connect it to the rest of your LAN.

thanks! I am still trying to figure out how to get to the EAP225 in such a way that there is internet access.

Found in docs site, Particularities of Single-Port Devices, which actually links to this outside blog TP-Link TL-WR703N – The perfect travel wireless AP (added to IA for posterity). This is the problem I am trying to solve. But I need to do it on the cli.

Have found lots of docs e.g. here, here and here but I can't tell how to apply any of that info.

Is there anywhere with slightly more brief, introductory information regarding cli rather than exhaustive reference?

Do it again and execute the following commands from the command line:

lanif=$(uci get network.lan.ifname)
uci -q delete network.lan
uci set network.lan="interface"
uci set network.lan.proto="dhcp"
uci set network.lan.type="bridge"
uci set network.lan.ifname="$lanif"
uci commit network
/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop
/etc/init.d/odhcpd disable
/etc/init.d/odhcpd stop
/etc/init.d/firewall disable
/etc/init.d/firewall stop

Restart the AP and connect it to the main router.
It should obtain the nessecary IP setting (from the DHCP server of the main router) to get Internet access.

Look in the status page of the main router to see what is the assigned IP address to the AP (for future access).

It’s a snapshot, so you don't have web GUI by default. You should ssh into the AP again and install it following the instruction.

thanks! i copy/pasted everything and it went in with no comment execpt the last line produced all these errors. is it still OK to restart?

root@OpenWrt:/etc/config# /etc/init.d/firewall stop
Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section @zone[1] (wan) cannot resolve device of network 'wan'
Warning: Section @zone[1] (wan) cannot resolve device of network 'wan6'
Warning: Section @zone[1] (wan) has no device, network, subnet or extra options
 * Flushing IPv4 filter table
 * Flushing IPv4 nat table
 * Flushing IPv4 mangle table
 * Flushing IPv6 filter table
 * Flushing IPv6 mangle table
 * Flushing conntrack table ...

That's OK. It's just saying it's not finding ipset and then proceeds as it should. Two things:

  • Use a 21.02 snapshot, those have a web interface. The EAP225-Wall is supported by the upcoming stable already.
  • Set your AP's IP address to something else than .1 (in the same subnet as your router!) so you connect to it directly (shouldn't matter whether you connect wired to your main router, or wirelessly to the AP directly).

There is no need to do any port forwarding whatsoever for your LAN. The dumb AP recipe you linked to would be what you need. The WDS instructions apply if you need a wireless bridge between your router and AP (which means: if you have no possibility to run a cable between both; that's still way more stable).

hey it works! thank you @pavelgl and @Borromini!!!

  • Can now see router OpenWRT on Router1's "Active DHCP Leases" page, ip
  • ssh root@ works and from there I can ping so it has internet.
  • don't seem to have any independent wifi turned on , which is expected since it's not been configured
  • next step: WAP tutorial (some already done above but not sure if permanent)

I was trying to figure out what version this is and was unable. cat /etc/banner doesn't tell because it's a snapshot. I guess 19.x? The download link doesn't tell.

Are you saying that I should abandon this attempt and go right for the newer one? I would do that for example via cli by using -sysupgrade.bin image (as described here)?

I am not sure what good the web interface will do now that this is all set up? On a different (proprietary) router that I had configured something like this, I'm not able to get to the web interface when it's set as AP; only to the primary one that's handing out the DHCP and such. Is there any benefit to having ability to use web console beyond initial install?

But I am hoping what you are saying is that I might be able to get a stable release for this thing instead of being on "snapshots" indefinitely.

I did look into all this before getting started, but you know, you always learn more in the doing. I don't think I understood/understand the "snapshot" concept. Like for instance just read today

a few hours after flashing the firmware you may not be able to install new modules with opkg any more

so anytime you want to install one thing you basically have to reinstall everything? I guess that would encourage a person to keep impeccable backups. (Or never install anything.) In this case that seems tolerable because it is just an AP and there's not tooo much fun to be had in any case. I think most of the configuration is on the mother device. But maybe I will learn otherwise.

Regular snapshots are built off master and never contain a web interface. You can use sysupgrade but to be sure use -n (ie wipe settings).

And yes, 21.02 will be officially released in the months to come. There's already an RC 1. You should use that one. Both the master and 21.02 snapshots get rebuilt frequently so the package compatibility issues apply to both (not to the RC and final release; that's a static set of packages).

OK I did it and it worked. :slight_smile:

Boy I almost missed this! Thank goodness. The idea that I'd have to start from scratch every time was really discouraging.

This thread has been an emotional roller coaster

:roller_coaster:. :roller_coaster: :roller_coaster:

you can always export the configuration between upgrades, and reimport it afterwards.

ya but it's just one more potential point of failure and one extra thing to do. Seems like it's a bit of a diceroll whether any given package will have a new error in it. So you go to change one little thing, but end up introducing a problem and now nothing works. Once functional, I would never want to touch it unless I had a day free to troubleshoot.

I am very capable of causing problems on my own, don't need this kind of help.