How to set up IPV6 with relay bridge

My setup is a BT Smart Hub providing my internet connection.

I now have a LEDE BT Home Hub 5a in a separate room. This is connected wirelessly to the BT Smart Hub and I have followed the instructions to set it up as a relayd pseudobridge. I have wired clients on the LEDE router who can connect and get an IPV4 address from the BT Smart Hub in the original Subnet and access the internet and other devices across the local network without any problem.

This is working nicely for IPV4.

However IPV6 doesn't work.

The router can get an IPV6 connection and the WWAN status gives me several addresses a
Prefix Delegated: /64, Address: /64 and a Gateway: fe80.....

However, lan devices connected to the LEDE router are not able to get an appropriate IPV6 address. I can deviate from the instructions and set up hybrid mode instead of relay mode, and then they then get an address with the appropriate prefix. However there is no IPV6 connectivity to the outside.

To be honest I am finding IPV6 extremely confusing and unintuitive.

How can I set up a route via the LEDE router and on to the BT Smart Hub for the LAN clients to access IPV6?

You can't, relayd doesn't work with IPv6. About a year ago there were some attempts to get support for this through linux-net, but it didn't lead anywhere.
WDS/ 4addr however can pass through IPv6 subnets, but it requires mainline wlan drivers based on nl80211 on both ends.

So no workaround at all?

Any suggestions before I bite the bullet and lay some cat6?

IPv4 is working so beautifully over the pseudobridge but I feel guilty about not being IPv6 compatible...

Have you tried relaying IPv6 RA/NDP with odhcpd?

Edit /etc/config/dhcp

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option ra 'relay'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wwan'
	option ignore '1'

config dhcp 'wan6'
	option interface 'wwan'
	option ra 'relay'
	option ndp 'relay'
	option master '1'

Then restart odhcpd via command /etc/init.d/odhcpd restart

Sorry to hijack this old thread. I'm trying to do the exact thing as the OP suggested here. I was able to config odhcpd as mentioned above. My client that is connected to the ethernet port (lan) is able to obtain an IPv6 address correctly. However, I'm not able to ping any external IPv6 hosts.

Topology: Client -> OpenWRT AP -> Ubiquiti UAP -> Ubiquiti USG -> Comcast

Any pointers on how to debug this further are highly appreciated.

I have the exact same problem (IPv6 adresses are assigned but routing isn't working). Is there really no solution for this?

I never got it working, just use IPv4. Causes some issues so would love to hear if anyone has the solution.