How to set up a router behind a proxy server

I have installed OpenWRT on Linksys WRT3200ACM. This router is positioned behind a proxy server without authentication. I can't find a way to integrate the parameters (address and port) in OpenWRT so that it connects to the Internet.
I have installed Squid but I can't figure out what to enter. Can you help me?
Thank you very much,

Network configuration :
computers, smartphone (WiFi) <--> router <--> Proxy <--> Internet

I haven't found the solution yet. Thanks to this article I was able to update the packages, so the router is well connected to the Internet. However, when I connect to WiFi from my smartphone, I still do not have an Internet connection without entering the proxy settings.
I feel like I've raked everything on the web.

I created a file in the /etc/profile.d/ directory containing:

export http_proxy = http: // address: port
export https_proxy = https: // address: port

I can now install packages but the terminals cannot connect to the internet. Maybe you need to do a port forwarding like here

Set up the proxy in the browser(s) on the clients.

1 Like

Thanks, but I want the people who connect not to have to configure anything in the proxy. I want to give them only the WPA key.

It may be necessary to do a port forwarding in IPtable but I admit that it is beyond my skills. I always try to understand the routes taken by the packets when we have a proxy.

I remind you my configuration
computers, smartphone (WiFi) <--> router <--> Proxy <--> Internet

Try redsocks, seems to do what you need.
haven't tried it myself, though.

Thanks. I'm going to look for this side. I'll come back and give the solution if it works