How to revert to stock firmware on R6220


I tried and wasn't satisfied by OpenWrt.
But now, when I follow the documentation for going back to the stock firmware, it doesn't work.

I just got

sudo ./nmrpflash -i enp0s31f6 -f R6220_V1.1.0.50_1.0.1.img -v
Adding to interface enp0s31f6.
Advertising NMRP server on enp0s31f6 ... -
No response after 60 seconds. Bailing out.

The computer is directly connected to the router, with a cable. No Wifi.
I tried different situation:

  • Router turned off, run the soft and immediately turn on the router.
  • Router on, I run the soft, then turn off the router, wait for a few second and turn it on again.
  • Same, but waiting for "Advertising NMRP..." to turn the router off and on.
  • Tried with the MAC address of the router.

I tried as well to run Wireshark, but I don't know what to look for. I don't know which lines are related to the router and so I don't know which mac address to pick.

What about the option "Flash new firmware image" into System, Backup/Flash Firmware from the web interface?
I can't find any documentation about it and rather prefer to not just try it and risk to brick my router.
Could this option be the simple way to do it ?

Use filter eth.addr == 00:11:22:33:44:55 where 00:...:55 the mac of the router.

Before you get a better answer, you may as well try to use an intermediate switch to make sure that the interface on the computer is up before you power on the router.

Which port on the router have you connected to the PC?
Did a forum search yield any usefull information?

Hi @trendy

Well I tried to add this filter, but as I understand it, the purpose was to get a different mac address the router may have when starting.
Not sure what I got did help me in any way...

I do not have a switch, only this router.
But considering what you were saying, I tried to set a manual IP, instead of the automatic one I had.
Running nmrpflash, it went forward

Adding to interface enp0s31f6.
Advertising NMRP server on enp0s31f6 ... |
Received configuration request from a0:63:91:1b:51:58.
Sending configuration:
Received upload request without filename.
Using remote filename 'R6220_V1.1.0.50_1.0.1.img'.
Uploading R6220_V1.1.0.50_1.0.1.img ... bind: Cannot assign requested address

The mac address is still the same, no surprise.
I don't know about that IP address...
And I didn't find anything useful about that error.

After that, it went back to its previous behavior...

@tmomas, I don't know, how can I found this information ?
I read some post about that operation, found nothing related to my issue.



Indeed, quite obvious seen like that. I haven't seen the back of my router since I bought it. Not in the place where it easy to have a look to it.
Nonetheless, the PC is on LAN2.

If you haven't yet got it flashed back to OEM, I can tell you my experience. I have taken two of these back to OEM and then tried new firmwares and then taken them back again.
My experience has been persistence using the nmrpflash.exe
The last time I took one back was two or three days ago, and I used Netgear's most current non beta firmware, I shortened the name of the IMG file to R6220-86.img, then from the command line I typed ran the command nmrpflash -L to see where my ethernet cable was designated and attached to my R6220 router. It showed as designated "net2"
So, at that point I typed in the command "nmrpflash -i net2 -f R6220-86.img" and then I powered off the router, next step was to power on router and immediately hit the enter for the typed command line entry.
Having the command line entry ready to enter immediately at the power up of the router was the key for me to reflash the OEM. If I waited more than a couple seconds it would not work.
I currently have two R6220s, one is on the OEM R6220-92.img and the other is on the OpenWrt 18.06.1 firmware.
edit: I am running the command line on my windows 8.1 PC, I didn't make that clear in my answer. So, if you have a PC, these steps should help get it flashed back. I haven't tried mac or linux machines running nmrpflash.

Hi @knowmansoul

Thank for your answer.
I tried reduce the name of the image file with no more success.
And also tried to fire the command as soon as I turned on the router. Not working either...

I'm indeed not running windows, but Debian 10.
As I don't have any computer running windows, I tried from a Virtual Machine (but hosted on the same computer...), still the same behavior...
I don't know what to do to go back to the stock firmware...

It is an odd issue, I have never had the problem you're facing.
As to the lan port, I haven't paid much attention to which one its plugged into, but, I know that I used Lan1 earlier this week.
Also, I did use the 30-30-30 Reset button technique prior to uploading.

Eventually, I tried again from another computer, running Ubuntu 18.
And it worked the first time, though I did flashed it again 3 times before having access to the router UI.

No big difference between the 2 computers, except the second was on LAN1 and running Ubuntu 18 instead of Debian 10. Also the second one was on DHCP, so it wasn't the problem.

Anyway, it worked and I'm finally back on the stock firmware.
Thanks for your help :smiley:

Glad to hear that you go it. Honestly, the persistence really is important to the task. I bricked another netgear router, I mean I used firmware from the wrong router and it appeared to be a lost cause, but, was able to use this command line utility and resurrect it from the dead.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.