How to restore the firmware of Mikrotik routerboard RB951Ui-2HnD

Good afternoon.
There are several routers Mikrotik RB951UI-2HnD, flashed temporarily under the project firmware OpenWRT everything worked. I want to return the standard RouterOS firmware. I saved the keys.
I set it up according to the instructions.
What I tried:

  1. Tried on different computers with different OS
  2. Changed the cable
  3. Used different versions of Netinstall
  4. Connected to different ports of the router
  5. Copied netinstall to the root of the disk With:
  6. Turned off the antivirus and firewall
  7. Held the button until the ACT light goes out, held it longer-20 seconds. Kept it even longer.
    The router does not appear in netinstall and that's it.
    1 router I was able to resuscitate, but I did not understand how it happened, I did everything the same. Apparently Openwrt blocks the recovery of the original Mikrotik firmware. How to solve this problem?

Your only option is Netinstall.
I have had the same problem as you and I got it with the reset at the bottom of the router. Use a Phillips screwdriver so that the tip of the screwdriver goes slightly into the hole and makes a good connection.
Do not trust the times given by the manufacturer, in some cases I have been more than a minute, just wait for your router to be displayed in Netinstall.

Waiting doesn't help, I've waited longer, there's no point in doing I see that the router is rebooting. I even pulled out the UTP cable, because the router is looking for a pxe server, as soon as I insert the cable, it immediately reboots. I can flash it with Tiny PXE server without any problems, but only under OpenWRT again. It turns out that the loader is working.

This is what has worked for me when I have had problems with Netinstall:

Connect the network cable to port 1.
Press reset, plug in, and keep pressing without releasing the reset button.
The ACT led turns on, then blinks for a few seconds, and then turns off.
In some instructions they say that we release the reset button at that moment, DO NOT DO IT !!!
We still have to keep pressing the reset button.
We will see that the led of port 1 will blink very fast, then it turns off for a moment, and then it turns on again, at that moment it should appear in the Netinstall window.
Now we can release the reset button, and start flashing.

Yes, I do. It doesn't help

Maybe it's obvious, but ... have you disabled the firewall?

I disabled firewall and antivirus. I installed a clean windows 10 32 bit, Windows 7, and even windows xp system for testing. Does not see Mikrotik. I have another Mikrotik model (Map lite) with RouterOS. I can see it in netinstall without any problems. Now I have installed OpenWRT specifically on MAp lite for testing. I see it in netinstall. The problem is with RB951UI-2HnD

How did you install OpenWRT on the RB951Ui-2HnD?

I'm happy to grab any of my 3 Rb951s and replicate your steps to see what's causing the issue

That would be cool)) I'll prepare the instructions and files. Thanks a lot


Saving the RouterOS license key

In the case of firmware with OpenWRT back to RouterOS, you will need a license key (read more To do this, you need to save it before flashing it to OpenWRT. The saving process:

  1. Connect to the router using Winbox or the web interface (more information about the first connection here:
  2. Open the console by clicking New Terminal in the control panel on the left, run the command
    /system license output
  3. Go to the File menu and copy the license file (named "RJ15 - ERX5.key") to your computer
  4. Save the matching file name and the router's MAC address (shown on the bottom cover).)

General information about the firmware

The device firmware consists of two stages:

  1. Loading an OpenWRT image with the extension into the router's RAM.elf using TFTP.
  2. Connect to the router that booted from the OpenWRT image in RAM, and write the OpenWRT image to permanent memory.

Step 1. Loading OpenWRT into RAM via TFTP

Connect to the router using Winbox or the web interface over Ethernet, make the following settings:

System → Routerboard → Settings → Boot device: Try ethernet once then NAND
System → Routerboard → Settings → Boot protocol: DHCP
System → Routerboard → Settings → Force Backup Booter: Checked

These settings will only be valid for one reboot of the router. If the firmware attempt fails, they must be performed again.

If the router is already flashed on OpenWRT, instead of the actions listed above, do the following:

Turn off the power to the router Press the Reset button And connect the power to the router
Watch the LED that shows the activity of the device (usually ACT or USR). First, it lights up, then flashes, then lights up again, then will turn off. After 5 seconds, the router will beep.
Release the Reset button

Next, you need to configure the DHCP / TFTP server to load the OpenWRT image into RAM.

Starting the DHCP and TFTP servers

Launch the Serva app.
Set the address on the computer's Ethernet adapter using standard operating system tools.
Run Serva32.exe. If a Firewall message appears that the application is blocked, allow it access to all networks by checking the appropriate boxes in the pop-up window.

Rebooting the router

Connect to the Ethernet connector 1. Restart the router on the power supply.
After these actions, the router will boot with the standard version of OpenWRT in RAM. This may take up to 3 minutes. The router will notify you of the download with an audible signal.

Step 2. Loading OpenWRT into permanent memory

After loading OpenWRT in RAM, in the case of firmware of a router with several Ethernet connectors, you need to reconnect the computer to connector 2. If the router has one Ethernet connector, you do not need to switch anything.

Executing the sysupgrade command

Download it putty.exe ( and winscp.exe (
Connect to the router using winscp.exe at, using the root username and an empty password, copy the rb951ui-2hnd-sysupgrade.bin to the /tmp folder.
Connect to the router using putty.exe, at, using the root username and an empty password, run the command sysupgrade /tmp/rb951ui-2hnd-sysupgrade.bin

Completing the flashing

The process may take several minutes. Wait for the router to restart. After that, the firmware process is complete. Now connect the cable to the second port. ON the network adapter, set receive address automatically. The adapter should get an address like 192.168.13. xx

1 Like

Put static IP on Lan port
See if you have other network cards enabled, even wifi -> disable it all
Then put RJ45 cable on first port (wan)
Open NetInstall and configure NetBooting with an IP next to your LAN port IP
After boot the device with reset pressed
Release the reset after devices shows on NetBooting
Now you can install your original firmware

This must work.

I had this exact problem and fixed the issue by using an older version of the netinstall tool that supports BOOTP rather than just DHCP.
When I was running wireshark I noticed I was seeing bootp requests with no response. When I downgraded to netinstall 6.32
Netinstall responded to the bootp request and I could flash on the older version of RouterOS then upgrade to the latest. The setting for bootp vs dhcp is under the RouterBOARD -> Settings and make sure the Boot Protocol is set to dhcp: