How to prohibit broadcasting ipv6 dns after enabling ipv6


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option local '/lan/'
	list server '/#/2001:da8::666#53'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	option ra_useleasetime '0'
	option ra_lifetime '600'
	option ra_mininterval '200'
	option ra_maxinterval '600'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ra_management '0'
	option leasetime '11m'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

I don’t want the following clients to get ipv6 dns, how to set it up, prohibit dhcp broadcasting ipv6 dns, I can do this on er-x, but I don’t know how to set it on openwrt.

You can try to advertise the same IPv4 DNS via both dnsmasq and odhcpd.

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '11m'
Connect to a specific DNS suffix.......: Lan
    IPv6 address..........: 2009:33d:9ae9:be00::109
    IPv6 address..........: 2009:33d:9ae9:be00:d469:6f61:a8f5:6d17
    IPv6 address..........: 2009:33d:9aeb:be00:d469:6f61:a8f5:6d17
    Temporary IPv6 address........: 2009:33d:9ae9:be00:493f:a6c3:e589:134a
    Temporary IPv6 address........: 2009:33d:9aeb:be00:40d9:85da:7abe:8061
    Link local IPv6 address...: fe80::d469:6f61:a8f5:6d17%20
    IPv4 address...........: 192.168.6.109
    Subnet mask............: 255.255.255.0
    Default gateway...........: Fe80::5e85:7eff:fe41:927e%20
                                        192.168.6.1

It still doesn’t work. Pushing new ipv6 is ranked at the bottom, but not at the top, so you still can’t access the Internet through ipv6.

    IPv6 address..........: 2009:33d:9aeb:be00:d469:6f61:a8f5:6d17
    Temporary IPv6 address........: 2009:33d:9aeb:be00:40d9:85da:7abe:8061

It is the ipv6 obtained after the router restarts, but it ranks at the bottom instead of becoming the first choice.

Isn't this about IPv6 DNS?
How is that related to IPv6 addresses?
Or, do you mean DHCPv6?

1 Like

I thought you were trying to disable this...

Disregard my instructions, then.