How to Port Forward?

So I'm planning to run my Minecraft Server publicly, the only problem is, how can port forward on LEDE? My router is TL-WR740N, and I switched to LEDE after knowing that my default firmware does not allow virtual server/port forwarding on a device connected via Wi-Fi.

Network>Firewall>Port Forwards

Hint: if you can't use google to figure out simple stuff, you're going to have a bad experience with a custom firmware.

1 Like

I know that, but I want it to be more broad, because I can't port forward it. When I use server query, it says offline, but I got my IP Address and Ports input correctly.

No offense but your post title indicates that you don't know that. You will need to be more direct when asking questions if you expect to engage members of the community to help you. You haven't provided an accurate description of your problem nor have you provided any data for people to go on to help you. For example, something as simple as a description and screen shot of what you did try that failed.

1 Like

I know that, I accept it

So this is my fullllllllll situation:
*I set the internal IP Address correctly
*I set the internal ports correctly (25565)
*I am connected using Wi-Fi which seems to be the issue. I think the port forwarding only works through Ethernet

I think you mean "more specific..."

Again, this information is insufficient to assist you. But I gathar from this, you gave the server a static IP, did you also properly assign a Gateway IP (router IP), DNS servers and subnet mask?

Also you noted you set the "internal ports correctly..." where did you have to set this port "internally" other than on the LEDE???

Incorrect, you can port forward to any IP-based host on your network, regardless of WiFi or Ethernet.

As @darksky noted, please provide a screenshot of the Port Forward you made in the LuCI web GUI, or a copy of the firewall entry from /etc/config/firewall

It should look something like this:

config redirect
option target 'DNAT'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '25565'
option dest_ip '192.168.1.x'
option dest_port '25565'
option name 'Minecraft'

This information is only helpful if someone on the forum specializes in setting up Minecraft servers...
:face_with_raised_eyebrow:

First you need to have your WAN set up to allow incoming connections. If your modem is acting as a router and double-NATting, the firewall in the modem will by default block all incoming connections.

Solutions to that are:

  • Bridge the modem, so the OpenWrt router has a public IP (best)
  • In the modem/router configuration, forward port 25565 to the OpenWrt router's WAN IP. (not to the final destination machine).
  • In the modem/router configuration, make the OpenWrt router the DMZ, meaning all ports are forwarded to it.

As already noted, this works with either a wired or WiFi connection in the LAN. It will even work with WiFi with stock firmware.

Hi guys,
I already fixed the problem by switching to other firmware, I'm sorry that I have to make a thread for this. I appreciate all your effort, but I think LEDE is not for me because my knowledge about networking/routers are not yet big because I'm only 16 yrs. old. But please don't get mad at me, I know that I might be stupid, and I'm sorry about that

Don't blame yourself!
Every journey begins with the first step!
Perhaps you'll return to Lede later. It's great!

2 Likes