How to modify router HG630v2 firmware?


i tried firmware-mod-toolkit
the extraction is working but when i tried to build firmware

isso@GIGABYTE-G41MT-S2PT:~/firmware-mod-kit$ sudo ./ 
Firmware Mod Kit (build) 0.99, (c)2011-2013 Craig Heffner, Jeremy Collake

Building new squashfs file system... (this may take several minutes!)
Squashfs block size is 1024 Kb
Parallel mksquashfs: Using 4 processors
Creating 4.0 filesystem on /home/isso/firmware-mod-kit/fmk/new-filesystem.squashfs, block size 1048576.
[=====================================================================================================================================================|] 1060/1060 100%
Exportable Squashfs 4.0 filesystem, xz compressed, data block size 1048576
	compressed data, compressed metadata, compressed fragments, compressed xattrs
	duplicates are removed
Filesystem size 5946.18 Kbytes (5.81 Mbytes)
	37.23% of uncompressed filesystem size (15971.71 Kbytes)
Inode table size 8902 bytes (8.69 Kbytes)
	21.96% of uncompressed inode table size (40546 bytes)
Directory table size 11356 bytes (11.09 Kbytes)
	44.76% of uncompressed directory table size (25373 bytes)
Number of duplicate files found 91
Number of inodes 1254
Number of files 1059
Number of fragments 14
Number of symbolic links  83
Number of device nodes 2
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 110
Number of ids (unique uids + gids) 1
Number of uids 1
	root (0)
Number of gids 1
	root (0)
Remaining free bytes in firmware image: 1428295
Processing 1 header(s) from /home/isso/firmware-mod-kit/fmk/new-firmware.bin...
Processing header at offset 6288841...sorry, this file type is not supported.
checksum update(s) failed!
CRC update failed.

Firmware header not supported; firmware checksums may be incorrect. 
New firmware image has been saved to: /home/isso/firmware-mod-kit/fmk/new-firmware.bin

how to overcome these errors i'm trying to enable telnet or ssh support for this modem

ask the person who created the script ?

it's not a supported device, here -

1 Like

the person who created isn't active, do you know how to build the firmware without this script the firmware is linux based like openwrt

so is 99% of all the other router firmwares out there, even those not supported by openwrt.

since the script appears to fail during CRC calculation, I could image it won't UL if the CRC isn't correct.

i'd rather check why it fails, instead of bypassing it.

1 Like