How to migrate simple WRT3200ACM LAN port configuration to 21.02.1, please?

I've been using OpenWrt v19.07.8 on a WRT3200ACM router for a few months now and I've been very happy with it so far. I thought it was time to upgrade my 'spare' WRT3200ACM to v21.02.1 but I'm having problems getting the LAN port configuration to work. I'm not doing anything complex, just using port lan4 as a separate subnet for some IOT devices.

I've read Converting to DSA and attempted to set my network configuration up accordingly but the IOT interface shows 'Error: Network device is not present' on LuCI and has a weird MAC. I've tried overriding the MAC to be the same as the LAN interface MAC (as it is on the IOT interface for v19.07.8) but that appears to have no effect.

Please could someone help me to get this working? I'm pretty new to configuring networks so I'd be very grateful if you assume I know virtually nothing ...

Thanks.

Here's the network config from my existing 19.07 router:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd44:1318:5788::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	option vid '2'

config interface 'guest'
	option proto 'static'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ipaddr '192.168.3.1'

config interface 'guest5G'
	option proto 'static'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ipaddr '192.168.2.1'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0 5t'

config interface 'iot'
	option ifname 'eth0.3'
	option proto 'static'
	option ipaddr '192.168.4.1'
	option netmask '255.255.255.0'

And here's the network config from the partly set up v21.02 router:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd94:e326:c303::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'ea:9f:80:1b:69:f8'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option type 'bridge'
	option name 'br-vlan4'
	list ports 'lan4'

config bridge-vlan
	option device 'br-vlan4'
	option vlan '3'
	list ports 'lan4:u*'

config interface 'IOT'
	option proto 'static'
	option device 'br-vlan4'
	option ipaddr '192.168.4.1'
	option netmask '255.255.255.0'

You do not need VLANs in 21.02 in this case.

  1. Remove LAN4 port from LAN interface
  2. Create a new interface IOT with a single member "LAN4 port"
  3. Add this new interface to the firewall zone

@Bluebell21 Not directly related to your original topic, but you might want to hold off upgrading to 21.02 until 21.02.2 is released. The 21.02 builds released thus far have had a wireless regression with mwlwifi and you will likely experience issues with the wireless radios, most likely a much worse experience than 19.07.

I would consider going back to 19.07 for now or you can run a 21.02 snapshot build which is between 21.02.1 and the unreleased 21.02.2, which has the fix. More info can be found on this thread.

If you aren't using the wireless functions (as you mentioned it's a spare router), then the above is probably not going to be an issue, but thought it was worth letting you know.

Thanks very much for the heads-up. There is a workaround for this problem which involves deleting all the 'option macaddr...' lines from /etc/config/wireless:

Do you have any idea when 21.02.2 will be released?

That was nice and simple, thanks. :grinning:

No confirmed release date for 21.02.2 currently. The temporary option is to use a 21-02 SNAPSHOT build instead, which is 21.02.1 with additional changes since the official release, but not officially branched to be 21.02.2 as of yet.

I did this setup a long time ago and just remembered something else: I set the firewall zone to not forward (DROP) between the interfaces in the zone. Can you test if the isolation actually works in your case? You might need this step.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.