How to migrate from default to VLAN on Totolink x5000r

Continuing the discussion from TOTOLINK X5000R missing SWITCH menu in network:

I am testing with this build:

[tolink_x5000r-squashfs-sysupgrade.bin](https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-totolink_x5000r-squashfs-sysupgrade.bin) 0e32463b081e6e2f1307d08aa8477d9a8ee643a07fe90cd15f395abcdc682328 6400.6 KB Fri Mar 18 20:40:32 2022

I want a VLAN based config similar to the non-DSA one below I am using this on a TP-Link WDR3600 (config listed at the bottom) .

I am doing the changes via Luci, starting from the default settings of the snapshot build.

  1. Goto Network->Interfaces->Devices
  2. Configure "br-lan", "Bridge VLAN Filtering"
  3. Add, enter 103 as VLAN ID, then apply

Then the config will fail to apply, and auto reverted back to previous config.

What is the procedure to use Luci to using VLAN based filtering of DSA?

# cat network (partial, from WDR3600)

config device
	option name 'eth0.2'
	option macaddr 'e8:de:27:b6:fa:8d'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1'
	option vid '2'

config device
	option type 'bridge'
	option name 'br102'
	list ports 'eth0.102'

config interface '102'
	option proto 'static'
	option device 'br102'
	option ipaddr '192.168.102.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '102'
	option description 'wdr3600'
	option ports '0t 2 3 4 5'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '101'
	option description 'c5v4'
	option ports '0t 2t 3t 4t 5t'
1 Like

same my issues, cannot apply config after make VLAN, no one help!

1 Like

I somehow can do the change using the latest snapshot during the weekend

I will test again and document the whole process this weekend.

Update: Safe Method

  1. Using LAN cable connecting to Port 1, computer should be in DHCP mode.
  2. Goto Luci->Network->Interfaces->Devices
  3. "Configure" 'br-lan'
  • In "Bridge ports", remove one of the free ports other than lan1 (I pick lan4).
  • save
  1. Save and apply
  2. In "Interfaces", add device, assign static IP address to port "lan4", setup dhcp server. save and apply
  3. switch computer from lan1 to lan4, it should get the new ip
  4. connect to Luci using new IP of lan4
  5. proceed to modify VLAN filtering of the "br-lan"
  6. after everything is done, connect to "lan1, lan2, lan3" and testing with each vlan as required.
  7. After everything works, remove Interface lan4 config, add lan4 back to br-lan, done.

This seems to be the minimal changes via Luci:

  1. Goto Network->Interfaces->Devices
  2. Add VLAN (default ID is 1)
  3. (lan1 is connected to computer), change lan1 to "un-tagged"
  4. save (do not apply)
  5. Go back to Interfaces
  6. Edit "LAN"
  7. Change 'Device' from "br-lan", to "br-lan.1"
  8. save and apply

Once configuration apply OK, can do extra changes as needed.

1 Like