How to install OpenWrt on WSR-2533DHPL router?

Hi all,
I have just seen today that the WSR-2533DHPL had been included in the supported routers for OpenWRT.
I am very interested in installing the new system to the router but after browsing OpenWRT website, some videos on YouTube I couldn’t understand how to do so.

My understanding of networking is very limited and I am sorry for that.
I have Windows 10 and my current WSR-2533DHPL firmware is the Buffalo v1.07.

After reading this part and see the video below:;a=commitdiff;h=e8787291b351a98a522ecc255a1da78394558588

my understanding is that I need to:

  1. Go to Buffalo router and change IP of router to
  2. Give IP address to windows PC of
  3. Create a TFTP server with “SolarWinds TFTP Server” software on my Win10. (
  4. Download the OpenWRT firmware from this URL:
  5. Rename the above bin file to “linux.trx-recovery“ and put it in the TFTP root folder in windows
  6. Do I need to turn off the windows PC firewall/antivirus?
  7. Connect the router to PC with TFTP server on LAN port 1 then power it and at the same time press the “AOSS” button (do I need to connect the router to the modem?)
  8. After 10 sec, release the “AOSS” button and the router will download automatically the image and boot
  9. After the above 8 points, do I have a web interface of OpenWRT on the router such as LuCI or do I need to install it through SSH or any other procedure? (described in the video but for another brand so probably irrelevant)
  10. If I have LuCI installed at STEP-8, I should download the OpenWRT upgrade from this URL:
    Then upgrade firmware through LuCI interface
  • Is the above understanding correct?
  • Also in the case I have any issue during the installation, what can I do to reset the router to its original form? Should I just repeat STEP-1 to STEP-8 but using the OEM factory firmware instead of the OpenWRT firmware? Or is it different?
  • I would like to use some specific tools such as VLAN from OpenWRT, is this included directly with the OpenWRT firmwares or do I have to install separate packages? How to do so if I need to download/install specific packages?

Comparing your description with the one in;a=commit;h=e8787291b351a98a522ecc255a1da78394558588 -> your description looks good to me

AFAIK yes, otherwise TFTP might not work.

Yes. Stable builds like 21.02.0 do include LuCI; master snapshots do not include LuCI.

Thanks a lot Tmomas for your very quick reply!
Since it is my first time joining OpenWRT journey, I learned many things looking at the different videos and webpages and I feel happy that it seems my understanding was somewhat correct!
I will then start the above process in a few and will keep you posted on the results.

Also, before I start do you know if:
a) I have to link the router to the internet while doing the procedure? I believe not since there is nothing to download from the internet with that router in the description linked
b) in the case I run in any issue during the installation, what can I do to reset the router to its original form? Should I just repeat STEP-1 to STEP-8 but using the OEM factory firmware instead of the OpenWRT firmware?
c) will all the packages (including VLAN) present within LuCI on OpenWRT 21.02.0 or do I need to install separately packages? If not included, do you know how to install those packages?

TFTP transfer on WSR-2533DHPL will be done by the U-Boot and it has by default, there is no need to set address.

Note: If the TFTP server software or TFTP service port (69) is allowed on the firewall (zone: public), there is no need to turn off.

There is no problem even if the upstream side is not connected. If anything, it is better to disconnect it to prevent unnecessary troubles.

Note: LuCI is not required during the installation phase.

Even if you are using the image without the web interface, you can upgrade to sysupgrade.bin image by using scp and sysupgrade command.
After releasing AOSS button and download/boot the initramfs image by WSR-2533DHPL, you can send the sysupgrade.bin image to the router from your computer via scp command (or sftp, anything). Then, you can perform upgrade by "sysupgrade" command.

using scp:
(after booting with the initramfs image)

  1. (on the computer) send sysupgrade.bin image to the router via scp
    ex.: scp openwrt-21.02.0-ramips-mt7621-buffalo_wsr-2533dhpl-squashfs-sysupgrade.bin root@

  2. login to the router via ssh

    ex.: ssh root@

  3. (on the router) perform sysupgrade with the sysupgrade.bin image

    ex.: sysupgrade /tmp/openwrt-21.02.0-ramips-mt7621-buffalo_wsr-2533dhpl-squashfs-sysupgrade.bin

Of course, if the image has the web interface, you can upgrade to the sysupgrade.bin image through it instead of using scp/sysupgrade command.

It can be done by using OpenWrt initramfs image and backed-up image from the flash chip before OpenWrt installation (or decrypted Buffalo's official image).

You can backup the original image when the booting with OpenWrt initramfs image for OpenWrt installation:

  1. login to the router via ssh

  2. dump partition from the flash chip
    - cat /proc/mtd (find "firmware" partition)
    - dd if=/dev/mtdblock3 of=/tmp/mtd3.bin (if "firmware" = mtd3)

  3. (on the computer) download the backed-up image from the router via scp
    ex.: scp root@ ./

Restoring to OEM firmware:

  1. boot with the OpenWrt initramfs image

  2. (on the computer) send backed-up image to the rotuer
    ex.: scp mtd3.bin root@

  3. (on the router) write backed-up image to the flash
    ex.: mtd write /tmp/mtd3.bin firmware

  4. reboot the router

VLAN support is included by default.
See the official document:

1 Like

Thanks @musashino and @tmomas,
I tried to SSH the router to backup the firmware but I wasn't able to connect to it (Connection refused on port 22). I tried to open my ports on windows firewall, port forwarding on the router but nothing worked. So I tried to flash the router without any backup and it did work!
Thanks a lot both of you for your support!

Now I am trying to:

I am a little lost as I know roughly nothing to VLANs and have checked some of the other posts with VLANs in OpenWRT where "switch" was not showing in interfaces but I couldn't understand much.

PS: Now that I have OpenWRT I can ssh my router so I think the problem was the buffalo OEM firmware blocking the connection.

<update 2021/09/11>
I managed to connect the buffalo router to the internet using the PPPoE credentials from my ISP.
After browsing for some time, I found this page: where it is showing the new way to create VLANs with the latest OpenWRT version.
Thanks to that post I managed to create the somewhat what I needed which was to separate networks within the same router using the I was able to use the "2. Multiple bridged networks" process but I couldn't create the different networks using the "3. Multiple networks using VLANs", the router was bugging and couldn't save the changes.
Would anyone know why? I was thinking of connecting 1 tagged port to another router so I could extend the whole network to another side of the house...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.