How to install on tplink mr200 v5

hi , i just bought mr200 v5.3 today only for installing openwrt and now i see its very hard to installing on this device .
i used lan cable on windows pc and a tftp tool. i set the pc ip to with mask and as gateway.
but nothing transfering at all , nothing log at all in log viewer tab .
and i press reset button for 5 second with connectin the power cable.

what did i do wrong? why there is no official manual for v5?

because it's not officially supported ?


This is how I did it on my MR200v4:

TFTP server IP address netmask Turn off all firewalls.

  1. Power off router
  2. Connect router to your TFTP server
  3. Press WPS/RESET while you power on router, keep pressed for 10s
  4. TFTP loading should now start
  5. Wait until router has restarted
  6. Log in with browser to
1 Like

its worked like a charm, thanks a lot.
but i cant find simcard setting to set APN. what should i do?
the original frimware is accessible? it hade the setting

you need to install the packages required for LTE/modem support.

1 Like

can you give their names or links ?

1 Like

modem is 4g and its need APN .
help me to install packages without internet .
this is the list of installed packages :

i also modified /etc/config/network and /etc/config/firewall according to :
but nothign happend

share internet from your phone, connect the MR200 to the phone's wifi.
or use to create a sysupgrade image containing all the extra packages you need for your modem.

did you do the verification described in ?

everytime i want to get builded images from frameware-selector error this :

Finalizing root filesystem...
Enabling adb-enablemodem
Enabling adguardhome
Enabling boot
Enabling bootcount
Enabling cron
Enabling dnsmasq
Enabling done
Enabling dropbear
Enabling firewall
Enabling gpio_switch
Enabling led
Enabling log
Enabling network
Enabling odhcpd
Enabling packet_steering
Enabling rpcd
Enabling sshtunnel
Enabling sysctl
Enabling sysfixtime
Enabling sysntpd
Enabling system
Enabling ucitrack
Enabling uhttpd
Enabling umount
Enabling urandom_seed
Enabling urngd
Enabling wpad

Building images...
Parallel mksquashfs: Using 4 processors
Creating 4.0 filesystem on /builder/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/root.squashfs, block size 262144.

[| ] 0/1675 0%
[=============================================================-] 1675/1675 100%

Exportable Squashfs 4.0 filesystem, xz compressed, data block size 262144
compressed data, compressed metadata, compressed fragments,
no xattrs, compressed ids
duplicates are removed
Filesystem size 13194.72 Kbytes (12.89 Mbytes)
24.18% of uncompressed filesystem size (54564.82 Kbytes)
Inode table size 12176 bytes (11.89 Kbytes)
19.46% of uncompressed inode table size (62554 bytes)
Directory table size 16218 bytes (15.84 Kbytes)
41.11% of uncompressed directory table size (39446 bytes)
Number of duplicate files found 248
Number of inodes 1880
Number of files 1524
Number of fragments 55
Number of symbolic links 235
Number of device nodes 1
Number of fifo nodes 0
Number of socket nodes 0
Number of directories 120
Number of hard-links 0
Number of ids (unique uids + gids) 1
Number of uids 1
unknown (0)
Number of gids 1

the packages i need : kmod-usb-serial-option kmod-usb-net-qmi-wwan uqmi luci-proto-qmi picocom sshtunnel luci-app-sshtunnel qmi-utils adguardhome

Feel free to review the PR though @amatur:

If there's anything not working (properly) just comment there.

so, wifi never came up again. i think i destroyed the modem

btw, every time i put qmi-utils in custom package installation in frimware-selector, its unable to build the images . i will do a PR for that later

Your device have insufficient flash space, no PR in the world is going to fix it.

i done the tftp again and device was up again , then i tried to systemupgrade bin upload. nothing happend yet

This is the minimum packages required to get the LTE modem to work:


If you don´t have internet access to your router, use WinSCP to move files from your computer to the router and install manually.


thanks , but where to download them

use the firmware selector again, and add them to the list of packages.

if it still fails, try an older release.

If you use 23.05.3, otherwise switch to your release.

kmod-usb-net-qmi-wwan and uqmi :

luci-proto-qmi :

1 Like

how run them after download? ./file?