How to install & configuration Aria2 downloader

Hi friends, Today I want Install Aria2 Downloader in BT Home Hub 5A but , After Install packsges USB & pakages Aria2 downloader.when I paste Url in to the Aria2 Downloader, File Doesn,t download in the USB.
In Aria2 Downloader write : Download was succedfull in red box & Size Of the File is 0KB ., I ,m Noob.
Please explain to me from the beginning to the end if possible. Preferably if possible with a picture.
Thank you very much for your help.

did you change the destination path for your DLds ?
is the USB storage device mounted ?

Sorry, I do not understand what you mean. Can you explain more? Yes, I mounted my flash.


Can you explain from the beginning the configuration required for the flash to the end, exactly what packages should I install and then how to configure them?

What is Dlds?

Linux is case sensitive, mnt isn't the same as Mnt, and it's usually mnt.

DLds = downloads.

Now I want Download Music But Doesn,t Work

/mnt/usb/download <> /mnt/sd1/download

Will these images help solve my problem?

is there a /mnt/usb/aria2 dir (again case sensitive) on the storage device ?

since you're logging your aria2 activity, what does the log say.

None Log !

well, the link works in aria, I just tried it, so it's something with your paths and permissions.

When I change the destination of the file to / tmp and I do not use Flash, it still does not work? Please explain to me the steps you have taken to set up Aria correctly. Thank you

I installed the packages, changed the path to /tmp, it worked instantly.

Using 21.02.2 btw.

That might not work, if the space's there.

My OpenWrt Ver : 19.07.8

try adding chmod 777 /mnt/usb to your local start up script, preceding the exit 0,
line hopefully the permission issue will be solved.

reboot afterwards.

1 Like

Hello, could it be because you entered this code? Because I saw this from a video on YouTube and then I imported it. But tonight, after deleting parts of this code and moving on with other parts, I managed to fix it, and I really thank you for your help, dear friend.

I put this code in the startup section :
# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.
aria2c --enable-rpc --rpc-listen-all --allow-overwrite=true --auto-file-renaming=false --continue=true --dir=/mnt/samba/download --max-connection-per-server=4 --max-concurrent-downloads=1 --max-resume-failure-tries=10 --daemon
exit 0