How to get full data throughput (solved)

Long intro an short question :wink:
I have an openwrt router ASUS RT-AC51U working as (unencrypted) tunnel endpoint. I have a 4G data uplink. load average of router is around 0.05 idle, when testing around 0.20.
I used 3 different devices to connect to a 4G network:

  1. ZTE with wlan connected to Openwrt
  2. TP-Link MR3020 and
  3. TP-Link MR6400, both with fast Ethernet port connected to Openwrt router.

The 4G connection supports download rates around 30 to 50 Mbps and upload rates from 15 to 30 Mbps. When I connect my smartphone or a laptop via wifi to the 4G devices directly I get download rates of 23 Mbit and upload rates between 4.5 to 5.2 Mbps (At the beginning of the test much faster but during the test limited due to limitation of 20/5 Mbps from account).

When I connect via fast ethernet to the openwrt router, I most times get around 10 to 12 Mbps, upload is regularly at 5 Mbps. The fast Ethernet (between openwrt and laptop) can give around 89 Mbps measured with iperf.

Question: Anything I can test or do to get the same performance on the ethernet link as I got with the 2.4Ghz wifi link ??? [thinking of NAT performance, firewall settings, known problems with the asus device, ... ] - (also tested: wifi between 4G router and openwrt-router does not reach those speeds too)
I just want to get my 20 Mbps through the openwrt device :wink:

Problem in this case was not the openwrt router hardware. Since the Uplink is performed via an (unencrypted) openvpn tap tunnel, the missing speed was due to speed loss over the tunnel. I tried some recommended settings in the openvpn config file, the best result was achieved with

fragment 1472 # (not much influence)
txqueuelen 1000 # (was at 100)
sndbuf 393216 # (was at 65536, higher values decreased throughput)
rcvbuf 393216 # (was at 65536, higher values decreased throughput)

direct connect over 4G router: (20-) 23 Mbit down 5 Mbit up
connect over openwrt router: (20-) 21 Mbit down 5 Mbit up

note: the output "speed: 10 Mb/s" of ethtool for a tap-interface is misleading and can be ignored.
~# ethtool tap07
Settings for tap07:
Supported ports: [ ]
Speed: 10Mb/s
Duplex: Full
Port: Twisted Pair

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.