How to flash OpenWrt on E7350 with latest firmware?

Got an E7350 running the latest factory firmware (Ver. I’ve tried to flash openwrt-ramips-mt7621-linksys_e7350-squashfs-factory.bin and it keep failing.

1 Like

try doing a reset, see if it downgrades itself.

Already tried that several times with no luck. After doing a little bit of research, I think the openwrt firmware might need to have some sort of embedded signature that a stock firmware file needs in order to accept it but I don't know how. I know it can be done because the E8450/RT3200 newer stock firmware apparently does the same thing and the openwrt developers managed to make a special initial flash file for openwrt to get the stock firmware to accept it.

1 Like

Are you getting any error message or is it just rebooting with the stock load?
I read somewhere that only one of the 2 partitions could be in my case after trying a few time (it kept on coming back to stock), I ended upgrading with the stock firmware once (to switch used partition) and then it worked right away...
You said yours came back with latest, so not sure if it is an option for you. Not sure if you can flash the same version than the running one....
Hope it helps.


It gets to about 33% on the flash, says “flash unsuccessful” and then reboots. :(. Unfortunately the stock firmware will not let you flash a previous version and any new firmware has to be “signed”.