How to fix low speed 'upload' for windows?

Hello everyone. Today I became an OpenWRT user. I'll say in advance that I've never used it, so I don't know much. The essence of the problem: on win7/8/10, the speed is "download 500 Mbit/s", "upload 10 Mbit/s". There is no problem with "low upload speed" on win11, Linux. I have two win 10 computers, and after changing the provider there was such a problem. I will not describe that I have tried everything in the world, but in the end I came to the conclusion that the problem is on the provider's servers. However, I had the idea that it was worth trying the OpenWRT firmware and today I installed the firmware on my TP-Link Archer C6 (AC1200) in the hope that the Linux kernel would help, but the situation has not changed. And I'm writing here to ask. Maybe there are some options to transfer traffic over the wire to the PC in a different way?
p.s. I understand that the problem does not apply to OpenWRT, but suddenly there are smart guys where who can somehow help get off the ground. I plan to solve this at least through the firmware just for myself and as soon as it works, I will write an email to the ethernet provider and send a huge report on my investigation of the problem.
p.s.s please do not write about windows drivers, wires, etc. It has already been rechecked, reinstalled many times. The problem is much deeper, but I need at least some kind of working solution.
Thank you in advance for any helpful hints

Lets start:
post output of

ubus call system board
cat /etc/config/wireless # remove passwords from output
cat /etc/config/network # remove MAC and IP addresses from output

Post test result link (no IP in report) from

Should be 1000Mbit/s wired and 400 or 800 wireless one way, a bit less simultaneous bidirectional.

I'm sorry, I'm completely ignorant. Where to enter it? I've worked with Linux, I understand. But I don't understand OpenWRT

in ssh session like putty or openwrt.lan
user: root password: as in web interface

1 Like


Cool, whats subscription specification - like cable? optical? 5g? and advertised speeds....
Also do another test over wifi (or cable, other way....)

Cable 5e, 1 gigabyte (4 pairs of conductors). I'm going to do a test from my phone now

Like subscription "DOCSIS internet 500/100"

1 Like

Result from my phone Samsung M31S (Wi-fi):

Do you see in the web interface under section network a sub-menu called "switch"?
Issue looks like ethernet pause frames on wired, and likely some minor misconfig on wifi.

Yes, I went in there. What should I do next?

On your PC disable ethernet flow control up and down. You have older swconfig switch which does not permit disabling those.

I didn't understand, I don't have the option to turn it off and on here.

Not there, you have to disable pause frames in client machine's network adapter. If that is enough we will see if it is possible to add setting to router via script or not....

How do I disable these pauses on the client computer?

In network adapter properties in windows, sometimes called pause, sometimes flow control.

I tried it. This did not solve the problem

Sorry to disapoint you, tplink was already linux.

Since it is 2x win10 affected id bet on windoes drivers and their always broken offloads.

Can you provide system and wifi info?

1 Like

What information do I need on wi-fi?
My PC:
Ryzen 7 2700x
64 gb ram
RTX 3060 ti
Samsung SSD 1 tb (system)

This thing

I cannot debug windows drivers. You need to contact your vendors.