How to fix broken router? (tp-link td-w8961n)

hello i've a tp-link td-w8961n after i flashed this router with wrong firmware he keeps rebooting
and reset the firmware, i don't have a TTL to USB adapter is there anyway to fix it i tried to connect via tftp but he didn't connect.i can connect to ftp and telnet but the router keep rebooting him self.
Wireless Chip :MT7592N
here's a video of the issue

This device is not supported by OpenWrt. You can try to recover by serial link, hoping that these infos from a related model are valid.

1 Like

You can also try to reprogram the eeprom (8pin chip between the capacitors). You'll need something like this.

Check according to your chip (unreadable on your picture). Real question : is it worthy considering your device?

This almost always requires a serial connection. It the lights blink that usually means the bootloader is OK and it can be contacted by serial.

The one other thing to try would be TFTP recovery. Most TP-Link models will enter TFTP mode if the power is turned on with the reset button held down-- keep holding until the WPS light flashes. If this mode is available, the bootloader is trying to contact a TFTP server to load new firmware. Usually the stock firmware .bin will work.

Picture shows MediaTek chips, so really there's no similarity with the 8960. The flash chip must be on the bottom of the board. The chip in between the capacitors is definitely a voltage regulator.


It is a rip off. I bought this for approximately 7 EUR only, directly from China including shipping.

And even if he has that SPI programmer, there is no guarantee the router will be ever back to stock, because he might have destroyed the ART partition, which is not recoverable.

So try TFTP and don't waste too much time on it.

I have noticed this afterward (OP added the picture). I was suggesting that models with very close references may behave in the same way for recovery.

i tried TFTP but unfortunately didn't work