Using the help of the forums, I managed to make a wifi network in upstream broadcasting the homelan vlan2. And the same thing but homelan broadcasts vlan1 from upstream to a wifi network.
In an effort to extend the network to another floor, I added a new router "extension" with a vlan4.
Using the router "extension", how can I broadcast two wifi networks, one connected to vlan 1 and another connected to vlan2?
homelab is connected to upstream in port 4 using ethernet cable.
extension is connected to upstream in port 3 using ethernet cable.
You need to use VLANs, so the wire that connects the main router to the extensions can carry more than one network. It's called "trunking", and basically consists in tagging several VLANs on the same wire. There are several posts in this forum about this scenario.
A simple summary on how to trunk: on lan3, you've set V:LAN 4 as untagged, correct? On the same interface add VLANs 1 and 2, as tagged. On extension, create two new virtual bridges with those VLANs, and new interfaces with those bridges. Make SSIDs and select those interfaces.
with the help of @psherman I was able to do two vlans (1,2) and extrend both wifi networks in each other router. Now I would like to add a third router to the mix to extrend the vlan1 and vlan2 but I'm lost with the tag and untagged assignments.
Currently I have
#upstream
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan2'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan3'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan4'
option macaddr 'aa:bb:cc:dd:ee:ff'
config interface 'lan'
option device 'br-lan.1'
option proto 'static'
option ipaddr '192.168.30.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'wan'
option macaddr 'aa:bb:cc:dd:ee:ff'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
list ports 'lan4:u*'
config bridge-vlan
option device 'br-lan'
option vlan '2'
list ports 'lan4:t'
config interface 'homelab'
option proto 'none'
option device 'br-lan.2'
# -------------------
#homelab
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'wan'
config device
option name 'lan1'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan2'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan3'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan4'
option macaddr 'aa:bb:cc:dd:ee:ff'
config interface 'lan'
option device 'br-lan.2'
option proto 'static'
option ipaddr '192.168.20.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'wan'
option macaddr 'aa:bb:cc:dd:ee:ff'
config bridge-vlan
option device 'br-lan'
option vlan '2'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
list ports 'lan4:u*'
list ports 'wan:t'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'wan:u*'
config interface 'upstream'
option proto 'dhcp'
option device 'br-lan.1'
option metric '10'
#----------------------------------------------------------------
#extension
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'wan'
config device
option name 'lan1'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan2'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan3'
option macaddr 'aa:bb:cc:dd:ee:ff'
config device
option name 'lan4'
option macaddr 'aa:bb:cc:dd:ee:ff'
config interface 'lan'
option device 'br-lan.4'
option proto 'static'
option ipaddr '192.168.40.1'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.30.1'
config device
option name 'wan'
option macaddr 'aa:bb:cc:dd:ee:ff'
config bridge-vlan
option device 'br-lan'
option vlan '4'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
list ports 'lan4:u*'
list ports 'wan:t'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'wan:u*'
config interface 'upstream'
option proto 'dhcp'
option device 'br-lan.1'
config bridge-vlan
option device 'br-lan'
option vlan '2'
list ports 'wan:t'
config interface 'homelab'
option proto 'dhcp'
option device 'br-lan.2'
When I configured extension I used the same port from upstream but now that the extension router is on another floor, and connected to upstream lan3 port, the vlans in extension are not working as intended.
We need to add port lan3 (tagged) to VLAN 2 in the upstream router:
config bridge-vlan
option device 'br-lan'
option vlan '2'
list ports 'lan3:t'
list ports 'lan4:t'
And if you want vlan4 to be available on the upstream router (originating from the extension router) to be broadcast as another wifi network, create vlan 4 and a network interface on the upstream like so:
config bridge-vlan
option device 'br-lan'
option vlan '4'
list ports 'lan3:t'
config interface 'extension'
option proto 'none'
option device 'br-lan.4'
That should theoretically be all that is necessary.
On the extension device, though, you seem to have addresses on the main network and the home lab… you don’t need to have this device hold an address from the home lab network, but you can if you want.