How to exit failsafe mode?

I've been resetting my router (Xiaomi Mi 4C) for fixing some issues, now that the issue is fixed, but every time I reboot the router, my configuration is gone, I'm still in failsafe mode? how to check it?

That behaviour might have two (eventually three) reasons:

  • you mistakenly flashed an initramfs image instead of a sysupgrade image
  • something prevents mounting the overlay
  • something (mechanical) keeps the reset button pressed

Before digging any deeper, I'd first visually inspect the reset button (with the router powered off) and press it a couple of times, if that's fine - flash the current version of OpenWrt again (sysupgrade image, don't keep settings, e.g. via sysupgrade -n /tmp/image-xxx.bin).

If that fixes the issue, great, case closed - if not, you'll need to check closer why the overlay doesn't get mounted, dmesg and logread should provide hints about that.


I tried to flash the image again, now it works normal, thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.