How to enable SLAAC for IPv6?

I want to enable SLAAC only for my WRT3200ACM, I searched the forum but there are no instructions to do it and I could not find anything in LUCI. Do I disable DHCPv6-Service in Interfaces > LAN? I disabled DHCPv6-Mode in IPv6 Settings and IPv6 in Android stopped working. I wanted static IPv6 for all the devices. What is the correct way to use SLAAC only in OpenWrt?

ipv6

from https://openwrt.org/docs/guide-user/network/ipv6/start#router_advertisement_dhcpv6

Example configuration section for SLAAC alone

cat /etc/config/dhcp
config dhcp lan
    option dhcpv6 disabled
    option ra server

cheers

1 Like

I disabled DHCP-Service and NDP-Proxy but Windows 10 is still getting random IPv6, Android is fine.

This is slightly confusing...with SLAAC, Android should get an IPv6 address...so should Windows 10...

To be clear, you set DHCPv6 as noted above, correct?

What did you expect it to get? SLAAC means it determines its own address. It will automatically create random ones to minimise tracking.

1 Like

working as intended, SLAAC = auto generated random address.

1 Like